Skip to Content
author's profile photo Former Member
Former Member

Wrong MDX-Query after changing Data Soruce

Hello,

i created some reports with CR 2008. Our data source is a test sap bi system. Now we want to go productive and switch the reports to the productive system. After i changed the data source in CR with "Set Data Souce Location" the MDX-Query become wrong.

Here the Query befor and after changing the source.

Befor:

  SELECT {[Measures].[D4J5LHGMY1IJ6LU4W8S02IM90], 
  [Measures].[D4J6E2RXCSKVPKWW7ICUJ87J8], 
  [Measures].[D4J6ER7MI3U5RXOP2NMFGU5GK], 
  [Measures].[D4JE2O5DX6ICJHRHEGDNZC84K]} ON COLUMNS,  
  NON EMPTY CROSSJOIN(EXCEPT([0PROFIT_CTR].MEMBERS, 
  {[0PROFIT_CTR].[All]}), [0ACCOUNT                      INT ZBWA].MEMBERS) 
  DIMENSION PROPERTIES [0PROFIT_CTR].[10PROFIT_CTR], 
  [0ACCOUNT                      INT ZBWA].[20ACCOUNT], 
  [0ACCOUNT                      INT ZBWA].[50ACCOUNT] ON ROWS 
  FROM [IPCA_C01/IPCA_C01_Q001] 
  SAP VARIABLES [!V000001] INCLUDING "2007", 
  [0P_CURRT] INCLUDING "10", 
  [0I_FPER] INCLUDING "001.2008" : "007.2008"

After:

  SELECT {[Measures].[D4J5LHGMY1IJ6LU4W8S02IM90], 
  [Measures].[D4J6E2RXCSKVPKWW7ICUJ87J8], 
  [Measures].[D4J6ER7MI3U5RXOP2NMFGU5GK], 
  [Measures].[D4JE2O5DX6ICJHRHEGDNZC84K]} ON COLUMNS,  
  NON EMPTY CROSSJOIN(EXCEPT([0PROFIT_CTR].MEMBERS, 
  {[0PROFIT_CTR].[All]}), [0ACCOUNT                      INT ZBWA].MEMBERS) 
  DIMENSION PROPERTIES [0PROFIT_CTR].[10PROFIT_CTR], 
X [0ACCOUNT                      INT ZBWA], 
  [0ACCOUNT                      INT ZBWA].[50ACCOUNT] ON ROWS 
  FROM [IPCA_C01/IPCA_C01_Q001] 
  SAP VARIABLES [!V000001] INCLUDING "2007", 
  [0P_CURRT] INCLUDING "10", 
  [0I_FPER] INCLUDING "001.2008" : "007.2008"

The X marked line in the after query is wrong and i dont know why... thanks for help

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Dec 04, 2008 at 02:22 PM

    Is there a [20ACCOUNT] object in your new source?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 04, 2008 at 02:23 PM

    Hi TimmaY

    If you look at the below statemsnt before and after the .[20ACCOUINT] is missing in you new inveronment. I think this is a field which is not exist in Productive system.

    Beofre :

    [0ACCOUNT INT ZBWA].[20ACCOUNT],

    After:

    [0ACCOUNT INT ZBWA],

    Thanks,

    Sastry

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.