Skip to Content
avatar image
Former Member

Catch 22 with new database having a full log

We need some help. One of our new non-production MaxDB databases has run into the situation where its log filled up before an initial backup was taken. Since no backup has been taken, we cannot activate autolog to resolve the full log situation. When we try to take a backup, we receive the following two errors:

-24755,ERR_SESSIONLIMIT: No session of type 'User' available

-24994,ERR_RTE: Runtime environment error 2,task limit

We presume this is because the database is not accepting any more activity due to the full log. How can we get a backup complete so we can then activate auto logging? If we can't get a backup at this point, how can we get the the autolog activated, or even set the log overwrite on temporarily to get us unstuck and allow the backup?

Any suggestions would be extremely welcome.

Thanks,

Clint

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Dec 03, 2008 at 08:46 PM

    Hello Clint,

    -> What is the version of your database?

    -> Please update with output of the command:

    x_cons <DB-Name> show active

    Thank you & best regards, Natalia Khlopina

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Clint,

      -> You have quit old database version 😔

      -> What is the value of the database parameter _MAXEVENTTASKS

      "Maximum number of event tasks

      The database system uses event tasks both for Event Dispatcher and for the DBM

      commands event_wait, event_receive, event_available, auto_extend and auto_update_statistics.

      These commands can be active simultaneously for this database instance.

      The default value of the Database Manager for this parameter is 2."

      -> Please update the ticket with output of the commands:

      dbmcli -s db_enum

      sdbregview -l

      xinstinfo QN2

      dbmcli -d <database_name> -u <dbm_user>,<password> dbm_configget RunEventDispatcher

      dbmcli -d <database_name> -u <dbm_user>,<password> param_directget _MAXEVENTTASKS

      dbmcli -d <database_name> -u <dbm_user>,<password> auto_extend show

      dbmcli -d <database_name> -u <dbm_user>,<password> auto_update_statistics show

      dbmcli -d <database_name> -u <dbm_user>,<password> event_list

      dbmevtdisp version

      dbmevtdisp state -d <database_name> -u <dbm_user>,<password>

      < You can stop the Event Dispatcher using dbmevtdisp stop >

      -> If auto_update_statistics & auto_extend are on, could you please deactivate them & see if you could create the complete databackup & log backup after that.

      Thank you & best regards, Natalia Khlopina

  • avatar image
    Former Member
    Dec 04, 2008 at 01:44 PM

    Lars, Natalia,

    Thank you very much for all your help. We noticed that the output from the "x_cons <db_name> show active" command resulted in 50 tasks being displayed, which was the limit set for MAXUSERTASKS for this database. We were able to increase that number dynamically in Database Manager. This then allowed us to connect in the normal fashion to obtain the initial backup.

    I also want to try the utility connection to see if that would have worked as well. We were sort of heading down that road before opening this thread, but were evidently doing something incorrectly.

    Once again, thank you both for your help. You have no idea how much it is appreciated as we have been having to learn MaxDB on the fly with no kind of training whatsoever.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 04, 2008 at 01:54 PM

    Closing out question. Thanks to Lars and Natalia for their fine assistance.

    Add comment
    10|10000 characters needed characters exceeded