Skip to Content
author's profile photo Former Member
Former Member

'Documentation link fails

The 'Documentation' link on my MII 12.0.4 home page fails to resolve properly. The link points to 'http://wbhelp.sap.com/manufacturing/xmii_120/{$Language}/43/E80B59AD40719AE10000000A1553F6/content.htm' but my MII account (coming from an LDAP data source) isn't providing the Language variable. When someone from our Basis group (with administrative rights and also coming from LDAP) uses the link, Language is available as 'en' and the link works properly.

What is the source of the Language variable? Why is it resolving properly with administrative rights but not developer rights?

Thanks for the help!

David Macindoe

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Dec 05, 2008 at 12:43 AM

    The {$Language} in the url comes from the DynamicHomePageLibrary.xsl that builds the home page itself for the logged in user. Whatever your particular custom home page theme is would likely inclue this xsl file such as: <xsl:include href="/XMII/CM/xMIIDS/Themes/DynamicHomePageLibrary.xsl"/>

    Your Language attribute is part of your profile which is the source of content used by the building process: /XMII/Illuminator?Service=SystemInfo&Mode=CurrentProfile&Content-Type=text/xml

    and then gets pulled into the help url with:

    <xsl:variable name="Language">

    <xsl:value-of select="/Profile/@Language"/>

    </xsl:variable>

    You will see at the top of the xml results for the above URL: <Profile .....Language="en"...... along with other typical ones like IllumLoginName and IllumLoginRoles.

    Do you not see this attribute or is it blank?

    In fact, /XMII/PropertyAccessServlet?Mode=List which shows all of the name/value pairs in the session should more or less line up with the attributes in your home page profile xml.

    Regards,

    Jeremy

    Add a comment
    10|10000 characters needed characters exceeded

    • Check the logs - make sure that it's not throwing an error for the xsl not being well formed. If the theme cannot be used (not found, error, etc.) then the system will default to it's default one.

      If it is effectively using your modified project theme but you are not seeing the changes you are making, then make sure you hit the Refresh link on the right that adds the extra refresh property to the URL:

      /XMII/Illuminator?service=Personalization&mode=refresh

      This forces the home page to rebuild without logging out and back in again

  • author's profile photo Former Member
    Former Member
    Posted on Dec 03, 2008 at 11:53 PM

    Hi,

    The language variable comes from the Netweaver User management.When a user is created,there is an option to select language as well. If you do not choose a language and leave it blank it will take the default language for the installed system.

    You can try to set English as language for your User ID and then test.Hope it works.

    Thanks

    Raman

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.