on 12-03-2008 3:04 PM
Hallo,
we designed a dashboard using QaaWS to connect to live data. On a local machine, the Xcelsius-swf works fine. Once I publish it to InfoView and open it online, the connection seems to be "unstable"? After several minutes (2 to 3) when I navigate the dashboard so the QaaWS has to refresh the data, I get the following error message for each QaaWS:
soapenv:Server.generalException: Unable to reconnect to the CMS. The session has been logged off or has expired. (FWM 01002)
After closing the dashboard, InfoView also shows an error message:
An error has occurred: Unable to reconnect to the CMS. The session has been logged off or has expired. (FWM 01002)
The timeout is set to 20 minutes, so this should not be the problem. Also, when I navigate through WebI, the InfoView connection stays stable. The problem seems to occur only when swfs, using QaaWS are opened.
Any suggestions what to do to keep the connection alive would be highly appreciated.
Thanks in advance!
I can confirm that I have the same issue.
It happens when I try to run an Xcelsius widget which has a QAAWS connection, from within InfoView.
Also when I try to logoff I get a javascript error:
Error:'name' is null on not an object
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SAP Note 1244342
Symptom
Request sent to QaaWS, BIPlatform, ReportEngine, or QueryService Web Services times out after 20 minutes.
Reproducing the Issue
Query as a Web Service
BIPlatform Web Service
ReportEngine Web Service
QueryService Web Service
Business Process BI Web Service
Cause
Default Enterprise Session timeout is set to 20 minutes on the Web Services Provider. Any request to the Web Services Provider that takes longer than that time to complete will encounter timeout errors.
Resolution
The value for the Enterprise Session timeout is modifiable by adding a property value to the dsws.properties file in the Web Services Provider web application.
This is found in the dswsbobje.war or BusinessProcessBI.war web application in the folder WEB-INF/classes.
Open the dsws.properties file, and enter a new line:
session.timeout=2400
where the value is in seconds - the above increases the timeout to 40 minutes.
We followed up with Support on SAP Note 1244342 and are hoping for some feedback....
-We added the timeout setting for dsws.properties per the SAP note 1244342 to just over 1 hour. However, this just pushes the behavior out 1 hour and is NOT a resolution.
-What we cannot determine is... if/how/when does the session.timeout "reset". Meaning, the user is presented with a .swf file on login. At that moment, the "clock starts" on the timeout. What action precisely resets/stops the timer from a session timeout perspective? If the user navigates to other objects in InfoView over the course of an hour that does not stop the dsws timeout clock they will get the error and have to shut down the browser and start over.
-We believe it is a defect that when the dsws timeout threshold is reached, you cannot simply log out/in within the same browser....you must close the browser and come back in. Please confirm this as by design or a defect. A better error message than FWM 01002 should be presented so the user knows it is just a timeout and to log back in.
Hi Kevin,
I have been having touble with Xcelsius and had seen a similar error to this. I was accessing through BI Widgets and the application was shutting down. I was also getting the same error, but had assumed the problem was with my server.
We reinstalled and created a new BOE environment and created a simple qaaws application. This ran fine updating 12 times a minute. At this point I closed the issue I had raised with the SAP/BO, concentrating on the other issues.
However, after I recreated my original dashboard, I found the problem reoccurred. The default session timeout was 1 minute. What I found was that I could get around the problem by refreshing the qaaws query more frequently than that. As my data was only really updating every 15 minutes this resulted in a lot of unncessary queries to the database but at least the user was not seeing the error
I then looked at creating the query through live office, as I noticed the a second dashobard I had created with Live Office did not seem to be suffering the same problem. I was able to get this working without the session time out and the high number of database queries.
I realise these are more workarounds the fixes but I hope it helps
Regards
Alan
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