Skip to Content
avatar image
Former Member

SAC Live Data Connection to SAP Universe (CORS)

Hi everyone,

I am trying to create a Live Data Connection to a SAP Universe on SAP BO 4.2SP4P7.

For the Path type, the issue is that everything inside the organization is set up with Nginx and not with Apache. Even tough I am able to reach from outside our CMC and BI.

1) Has anyone have played with Nginx?

For the Direct connection I use KBA 1185443 and 1648573 to enable SSL on Tomcat. In order to enalbe WACS based on two entries (blog and Q&A) I use KBA 1618311: WACS is running with errors.

I generate the keystore like follow based on KBA 2433337 and the last parameter I added because of a Chrome Warning (Subject Alternative Name). I also followed the KBA 2482807.

-genkey -alias WACS -keysize 2048 -keyalg RSA -ext
-import -alias ca_alias -trustcacerts -file <ca_path>\ca-chain.cert.pem
-keystore <key_path>\.keystore

And I am able to access to the BO-Server with a secure connectio like https://<bo-server>:8443/BOE/CMC

2) I tried with port 443 & 8443 does this make any difference by direct connection?

We are trying to troubleshoot "Failed to connect to system". We tried both deployments with cs_ina_agent.war file then undeployed and delete the context from server.xml and rename sap#boc#ina.war and deployed. Still we are not able to connect. We followed this KBAS:

  • KBA 2523372 -> Failed to connect to system in SAP Analytics Cloud (BOC)
  • KBA 2525754 -> Failed to connect to system in SAP Analytics Cloud (BOC)
  • KBA 2544696 -> Failed to connect to system in SAP Analytics Cloud *** Master KBA ***

  • HTTPS Certificate: is secured
  • Authetication method: enterprise
  • CORS configuration: " SocketException invoking http://<bo-server>:<cms-port>/biprws/logon/long: Connection reset"

  • KBA 2596646 -> Failed to connect to System in SAP Analytics Cloud (SAC)
  • KBA 2628148 -> Unauthorized from GetServerInfo for Live Data Connection to SAP Universes in SAP Analytics Cloud (SAC)
  • KBA 2628222 -> Live Data Connection to SAP Universes fails in SAP Analytics Cloud (SAC)
  • 3) Has anyone run into something like this?

    Thanks in advanced,

    Diana Chávez

    Add comment
    10|10000 characters needed characters exceeded

    • Follow
    • Get RSS Feed

    2 Answers

    • Best Answer
      May 18, 2018 at 06:04 PM


      So, it can be a little tricky, when the SSL certificate is self-signed. Let's check the SSL certificate is not the issue, since often it is.

      Clean your browser cache/history. Close the browser and start it up again.

      Get your browser to trust that certificate before you use the CORS connection. To do this, you need to go to your httpS://WEBAPPSERVER:8443/ (the host hosting the cs_ina_agent web app) and then click on the 'Advanced' - 'Proceed to localhost (unsafe)'.

      Then, when your browser uses CORS to connect directly to the host hosting the cs_ina_agent it won't complain about the lack of trust it has for the SSL certificate.

      Is your issue with both PATH (reverse proxy) and DIRECT (cors) connections? Which one works?

      Regards, Matthew

      Add comment
      10|10000 characters needed characters exceeded

    • avatar image
      Former Member
      May 22, 2018 at 12:50 PM

      Hi Matthew,

      Thanks for your answer.

      First I imported the chain certificate from my organization into the keystore. After that, the first time I try to access the BO-Server with HTTPS I was having an unsafe connection, but then I saw the certificate through F12 (Developer Tools), save it and imported into my trusted root certificates.

      I cleared the cache/history from my browser and when I gave httpS://WEBAPPSERVER:8443/sap/boc/ina/GetServerInfo and get the following message:

      {"Messages":[{"Type":2,"MessageClass":" SocketException invoking http://<IP_WebAppServer>:6400/biprws/logon/long: Connection reset\r\n\tat org.apache.cxf.jaxrs.client.WebClient.doResponse(\r\n\tat org.apache.cxf.jaxrs.client.WebClient.doChainedInvocation(\r\n\tat org.apache.cxf.jaxrs.client.WebClient.doInvoke(\r\n\tat org.apache.cxf.jaxrs.client.WebClient.doInvoke(\r\n\tat org.apache.cxf.jaxrs.client.WebClient.invoke(\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat javax.servlet.http.HttpServlet.service(\r\n\tat javax.servlet.http.HttpServlet.service(\r\n\tat org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(\r\n\tat org.apache.catalina.core.ApplicationFilterChain.doFilter(\r\n\tat org.apache.tomcat.websocket.server.WsFilter.doFilter(\r\n\tat org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(\r\n\tat org.apache.catalina.core.ApplicationFilterChain.doFilter(\r\n\tat org.apache.catalina.filters.CorsFilter.handleNonCORS(\r\n\tat org.apache.catalina.filters.CorsFilter.doFilter(\r\n\tat org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(\r\n\tat org.apache.catalina.core.ApplicationFilterChain.doFilter(\r\n\tat org.apache.catalina.filters.RestCsrfPreventionFilter.doFilter(\r\n\tat org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(\r\n\tat org.apache.catalina.core.ApplicationFilterChain.doFilter(\r\n\tat org.apache.catalina.core.StandardWrapperValve.invoke(\r\n\tat org.apache.catalina.core.StandardContextValve.invoke(\r\n\tat org.apache.catalina.core.StandardHostValve.invoke(\r\n\tat org.apache.catalina.valves.ErrorReportValve.invoke(\r\n\tat org.apache.catalina.core.StandardEngineValve.invoke(\r\n\tat org.apache.catalina.connector.CoyoteAdapter.service(\r\n\tat org.apache.coyote.http11.AbstractHttp11Processor.process(\r\n\tat org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(\r\n\tat$SocketProcessor.doRun(\r\n\tat$\r\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(\r\n\tat java.util.concurrent.ThreadPoolExecutor$\r\n\tat org.apache.tomcat.util.threads.TaskThread$\r\n\tat\r\nCaused by: SocketException invoking http://<IP_WebAppServer>:6400/biprws/logon/long: Connection reset\r\n\tat org.apache.cxf.jaxrs.client.AbstractClient.checkClientException(\r\n\tat org.apache.cxf.jaxrs.client.AbstractClient.preProcessResult(\r\n\tat org.apache.cxf.jaxrs.client.WebClient.doResponse(\r\n\t... 38 more\r\nCaused by: SocketException invoking http://<IP_WebAppServer>:6400/biprws/logon/long: Connection reset\r\n\tat sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)\r\n\tat sun.reflect.NativeConstructorAccessorImpl.newInstance(\r\n\tat sun.reflect.DelegatingConstructorAccessorImpl.newInstance(\r\n\tat java.lang.reflect.Constructor.newInstance(\r\n\tat org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.mapException(\r\n\tat org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.close(\r\n\tat org.apache.cxf.transport.AbstractConduit.close(\r\n\tat org.apache.cxf.transport.http.HTTPConduit.close(\r\n\tat org.apache.cxf.interceptor.MessageSenderInterceptor$MessageSenderEndingInterceptor.handleMessage(\r\n\tat org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(\r\n\tat org.apache.cxf.jaxrs.client.AbstractClient.doRunInterceptorChain(\r\n\tat org.apache.cxf.jaxrs.client.WebClient.doChainedInvocation(\r\n\t... 37 more\r\nCaused by: Connection reset\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat\r\n\tat org.apache.cxf.transport.http.URLConnectionHTTPConduit$URLConnectionWrappedOutputStream.getResponseCode(\r\n\tat org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponseInternal(\r\n\tat org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponse(\r\n\tat org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.close(\r\n\t... 43 more\r\n","Number":0,"Text":" SocketException invoking http://<IP_WebAppServer>:6400/biprws/logon/long: Connection reset","ExceptionClass":""}]}<br>

      For the Path (Reverse Proxy), I am able to connect through Nginx to httpS://<domain>/BOE/CMC and also httpS://<domain>/BOE/BI but do not have a <path> define in the Ngnix configuration.

      I am focusing on the direct (CORS) connection. But none of them is working.



      PS Found the error we used the port of the CMS on the instead of the RESTfull Services, that was my mistake.

      Add comment
      10|10000 characters needed characters exceeded