Skip to Content

An inconsistency occurs in the model for the logical system for program ESH_TEST_SEARCH

Hi,

We want to setup Enterprise search in the Front-end system(FES). Found out that I would have to setup Fiori Search first in FES.The Front-end system(FES) is on SAPNW 7.50 SP9 with HANA 2.0. During the setup, tasklist SAP_ESH_INITIAL_SETUP_WRK_CLIENT asked for the software component but since SAP_APPL is not installed in this system, so it was decided to utilize the SW SAPAPPLH from the backend system(BES). The backend system is on SAP NW 7.4 SP5 on HANA 2.0. Configured FES as proxy and BES as backend system via tcode ESH_REG_REMSEARCH and the connectors showed up in ESH_COCKPIT in FES. Now the problem is that Fiori search still doesn't show up in FES. Also the consistency check for report ESH_TEST_SEARCH fails with the error " An inconsistency occurs in the model for the logical system" in FES while the check if fine in the BES system. Tried deleting the connectors via SAP_ESH_RESET and ran the tasklist SAP_ESH_INITIAL_SETUP_WRK_CLIENT again in the system but the error persists in program ESH_TEST_SEARCH Also completed the setup in backend system as per this SAP Reference link: https://help.sap.com/fiori_bs2013/helpdata/en/12/af5252b10d5a64e10000000a423f68/content.htm?no_cache=true#jump121

Please advise on how to fix this issue.

Thanks

Rachit

screenshot1.png

screenshot2.png

screenshot1.png (150.2 kB)
screenshot2.png (14.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • May 18 at 06:58 AM

    Hello Rachit,

    So in your BES backend system, all your connectors should be active. Please try again to execute task list SAP_ESH_CREATE_INDEX_SC with SAPAPPLH Software Component and also tick the step "Delete Connectors". Execute it in background. Once this has been executed succesfully, you can execute report ESH_REFRESH_RUNTIME_BUFFER in SE38.

    In your FES frontend system, please check out if you can see BES search connectors in ESH_COCKPIT, run report ESH_REFRESH_RUNTIME_BUFFER and try to search again on these connectors using ESH_TEST_SEARCH.

    Please let me know if that works. Kind Regards,

    Christine

    Add comment
    10|10000 characters needed characters exceeded

  • May 23 at 05:46 AM

    Hi Christine,

    Thanks for the reply. The connectors are active in the BES system but the tasklist SAP_ESH_CREATE_INDEX_SC is not available since the system is on SAP NW 7.4 SP5. We had to configure Enterprise search manually on this system via SPRO. I do see that the connectors are active on the backend. On the frontend system FES, we are now getting the same issue as reported in SAP note 2227082 - Search fails in SAP Fiori Launchpad but is successful in 'Enterprise Search'. We have configured a SAP Webdispatcher between FES and BES but the Fiori search points to FES instead of using the redirect rule in WD for /sap/es/ina for BES. Do you have any idea about how to fix this issue.

    Thanks

    Rachit

    Add comment
    10|10000 characters needed characters exceeded