Skip to Content
avatar image
Former Member

Message Servlet is in Status OK SOAP sender Synch call

Dear ALL,

My scenario is SOAP to RFC scencronous via PI.

Does any one know the exact solution to the below mentioned problem:

Message Servlet is in Status OK

Status information:

Servlet com.sap.aii.adapter.soap.web.MessageServlet (Version $Id: //tc/xpi.adapters/NW07_04_REL/src/_soap_application_web_module/webm/api/com/sap/aii/adapter/soap/web/MessageServlet.java#1 $) bound to /MessageServlet

Classname ModuleProcessor: null

Lookupname for localModuleProcessorLookupName: localejbs/ModuleProcessorBean

Lookupname for remoteModuleProcessorLookupName: null

ModuleProcessorClass not instantiated

ModuleProcessorLocal is Instance of $Proxy85_10002

ModuleProcessorRemote not instantiated.

I have solved the same problem many times by refreshing the caches. Now i am facing the same after refresh of the caches also. Thanks in advance.

Regards,

Venu V

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Nov 28, 2008 at 11:27 AM

    Hi

    Look similar thread till end

    saop-adapter-error

    http-to-soap-scenario

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 28, 2008 at 11:46 AM

    Hi Venu,

    Are you using any module ?

    In RFC adapter on module tab check if you have any empty row for module.

    Or the Default module name RFCModule (It exists by default) is existing.

    Else if you are trying to use modle for SOAP sender then it(SOAP Sender Adapter) does not possible coz it does not support the module.

    Thanks

    Sunil Singh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi  Rajesh,

      I am sorry, I should have explained, how it has been solved.

      I had problem at that time due to having * in party in configuration object (in ID) and not having that in URL. That * came when I used the wizard for configuring the ID objects. So I have maintained that * in my URL, after that it was resolved.

      In your case there might be some minor issue like that should have causing the problem. Generate the WSDL file and test the same using SOAP UI and check if you are able to hit the PI or not.

      For SOAP Sender URL, please refer SAP help.

      http://help.sap.com/saphelp_nw73/helpdata/en/48/3555240bea31c3e10000000a42189d/frameset.htm

      Thanks & Regards,

      Venu V