Skip to Content
0
Nov 25, 2008 at 08:07 PM

External data transfer with KEFC.

4333 Views

Hi,

We are trying to make an upload of a cvs file with tcode KEFC with SAP ECC 6.0.

We have defined the structure and the transfer rules (KEFA and KEFB).

The same file has been used with SAP 4.6 with the same structure and transfer rules.

The upload has been made correctly on 4.6 while for ECC 6.0 we have a problem.

The screen after the upload gives a list with the data read from the csv file, and for some field the value is missing (GJAHR, PERBL and MENGE).

Opening the log generated, an empy list of the errors is shown (the light is red but all the record are blank).

I don't know if the problem is related to the file, but uploading the same file in 4.6, the transfer data is correct.

We have created the same structure for the two environments with the same field and the same lenght:

(KEFA)

Sender field 4.6 Type 4.6 Lenght 4.6 Sender field 6.0 Type 6.0 Lenght 6.0

BUKRS CHAR 4 BUKRS CHAR 4

WERKS CHAR 4 WERKS CHAR 4

ARTNR CHAR 18 ARTNR CHAR 18

KOKRS CHAR 4 KOKRS CHAR 4

GJAHR NUMC 4 GJAHR NUMC 4

PERBL NUMC 7 PERBL NUMC 7

ABSMG_ME UNIT 3 ABSMG_ME UNIT 3

MENGE NUMC 12 MENGE NUMC 12

VRGAR CHAR 1 VRGAR CHAR 1

VERSI CHAR 3 VERSI CHAR 3

VKORG CHAR 4 VKORG CHAR 4

KNDNR CHAR 10 KNDNR CHAR 10

VTWEG CHAR 2 VTWEG CHAR 2

KTGRD CHAR 2 KTGRD CHAR 2

PLTYP CHAR 2 PLTYP CHAR 2

but we have identified a difference during the setting of the transfer rule (KEFB): in the 4.6 the sender field have a different lenght from the same ones in the ECC 6.0.

We have tried to re-create a new structure, but the sender field lenght remain the same.

Do you know which is the problem? Could be possible that the cause is this difference between the field lenght? If yes, how we can solve this problem?

Thanks a lot for your collaboration,

Regards,

Jody Mancini.