Skip to Content

How to set UI5 version for standalone apps in Java Portal?

Hello all,

I am struggling with version differences of standalone UI5 apps (UI5 iViews) and Launchpad apps. I have enabled Fiori 2.0 design and activated the 1.52.X sources. In the FLP everything is just fine but standalone apps always run with 1.38.X. Is there any way to get every UI5 app running with the newest available build on the portal?

--> System is NW 7.5 SP11

BR and Thanks,

Tobias

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • May 17 at 11:43 AM

    Hi Tobias,

    The standalone apps do not use the bootstrap from the launchpad, but its own bootstrap. So maybe you need to modify the UI5 resouces in the bootstrap of the app as per the following documentation:

    https://sapui5.hana.ondemand.com/#/topic/a04b0d10fb494d1cb722b9e341b584ba

    Best regards,

    Désirée

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Désirée and thanks for your answer. I thought about that too but imagine if you upgrade your portal and have a newer version of UI5. In this case you would have to change a lot of static version references in the application bootstraps :/. If there is no other way, I will consider this option since current default is 1.38.x and with static reference i would have 1.52.x at least.

      Best regards,

      Tobias