Skip to Content
avatar image
Former Member

IDOC with custom segment: z-fields out of order

Hi experts,

I'm working in an IDOC 2 IDOC scenario with a graphical mapping. The IDOCs have a custom segment.

When processing the IDOC is well generated at origen then well mapped in PI (the fields match with the expected values in SXMB_MONI). But, when arriving to destiny the values of the fields of the custom segment doesn't match with their expected values. So, the IDOC fields are fine in PI in SXMB_MONI but are out of order in WE19. The expected values are disgregated between the different fields.

This problem just happend in the custom segment fields, for the standard fields everything is fine.

Any idea?

Regards

Gonzalo

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Nov 25, 2008 at 11:42 AM

    Hi Gonzalo,

    As I understood your query properly , you are not able to get the new updated custom z fields segment at recieving application. Correct me If I am wrong in understanding your query.

    If that is the case just then do the step as mentioned below:

    Request you to delete the earlier content of IDOC metadata from IDX2 and import the new content of Standard IDOC with custom field segments.

    Thanks & Regards

    Prabhat

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 25, 2008 at 09:58 AM

    Hi ,

    The records gets filled up because of the ALE configuration which is done .

    to sort out this problem uncheck the parameter "Apply control records from payload" at the communication channel.

    Do give SOme default values to the Segment parameters.

    If still the problem still exists ....

    Please provide me the payload which is coming in XI @ sxmb_moni and the original data which you recive @ the IDOC

    Edited by: Sainath Chutke on Nov 25, 2008 10:59 AM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 25, 2008 at 09:59 AM

    can u check the value of input payload and output payload in SXMB_MONI for that custome segment whether both are same or not?

    chirag

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 25, 2008 at 11:24 AM

    Hi,

    I have changed the communication channel parameter (Apply Control Record Values from payload) but the the problem remains.

    In the SXMB_MONI I have the maximum trace level and I'm watching the message before the mapping (response- > Payload). You can see here an example:

    [Comparation SXMB_MONI - and WE19|http://img291.imageshack.us/img291/8357/erroridocbk6.jpg]

    As you can see the segment Z1BKPF changes somewhere before it is send from PI and/or it is not well interpreted in the backend. However the standart segment fields, for example fields in E1F1EKPF, arrive fine.

    Regards

    Gonzalo

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      OK, doing wat you said I have just find out that the IDOC fields went wrong since they arrive to PI.

      My scenario is R3- > PI -> R3 (IDOC 2 IDOC) with the same IDOC type in both systems. And what I have just find out is that the message is not well sent from R3 in first place.

      In We19 for example there are 2 fields with values 'FIFI' and 'I'. And in PI arrives both fields concatenated in another different field as <PROV_LUGAR_EMISION> FIFI I</PROV_LUGAR_EMISION>.

      Does that helps?

      Regards

      Gonzalo

  • avatar image
    Former Member
    Nov 25, 2008 at 03:13 PM

    Finally the problem lied in the IDX2 import of the IDOC in PI. I have importedit in a first moment, then the IDOC fields where changed in R3 source and that was the reason why the fields were wrong populated.

    Thanks for your help.

    Regards

    Gonzalo

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Gonazalo,

      So the solution I mentioned was correct for you.

      Thanks for updating the forum.

      if you have assigned the points request you to close the thread.

      Thanks & Regards

      Prabhat