Skip to Content
avatar image
Former Member

Webservice Error. Please help...

Dear all,

I have an issue in my web service based PI scenario. Sender and Receiver side I am using SOAP.

A message comes from portal to PI and from there the message goes to Siebel. The communication is asynchronous (like data insert).

The Siebel team has provided me with the xsd (which I used in the sender/source structure) and Reciever side I have used the wsdl file provided by them. The xsd and the wsdl contains the same data.

When we tested this interface; sender AE: SUCCESS; IE: SUCCESS; Receiver AE: System Error.

From the portal side whenever we send data to PI we are getting "null pointer exception"; eventhough the message has got succesfully posted in PI. In the receiver AE audit logs I am getting the below error:

2008-11-24 20:51:21 Error MP: Exception caught with cause com.sap.aii.af.ra.ms.api.RecoverableException: SOAP: response message contains an error Application/UNKNOWN/APPLICATION_ERROR - application fault

2008-11-24 20:51:21 Error Exception caught by adapter framework: SOAP: response message contains an error Application/UNKNOWN/APPLICATION_ERROR - application fault

2008-11-24 20:51:21 Error Delivery of the message to the application using connection SOAP_http://sap.com/xi/XI/System failed, due to: com.sap.aii.af.ra.ms.api.RecoverableException: SOAP: response message contains an error Application/UNKNOWN/APPLICATION_ERROR - application fault.

We checked the Siebel side; we could see that the data has come to Siebel, since the Siebel logs have our data in it. So there cannot be any connection problem. But the insert has not happened.

When I tried sending the same data; same wsdl through SOAP UI; the data record is getting inserted in Siebel.

Please tell me where could the problem be and suggest possible resolution methods... Thank you in advance.

Regards,

Smitha

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Nov 25, 2008 at 06:32 AM

    Hi,

    Check if it is bcoz of wrong format which is not supported by XI as discussed in thread

    question-application-error-when-using-soap-sender

    Thanks!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sudhir,

      But in that case the message sgould fail in the message mapping, right? I can see that the status of the message in IE is success. I had noticed that the data elements in the target wsdl of string type is defined as: string30, string1, string 50 etc. Could this be a problem? But since I did not see any failures in message mapping, I ruled this out... Also, the wsdl file has many elements so I cannot manually create a data type.

      What do you think?

      Thank you

      Regards,

      Smitha