Skip to Content
0

missing column in BODS

Nov 04, 2016 at 01:37 PM

102

avatar image
Former Member

In a BODS JOB we are using a table comparison to an attribute view on HANA. This works fine the DEV environment. but on Acc I keep getting a missing column message during run-time.

The JOB validates ok and data preview shows the column as expected. I tried a reimport and re-adding the table to the mapping operator.

Any pointers on what might be causing this issue ?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Aasavari Bhave
Nov 04, 2016 at 01:45 PM
0

do you use sorted input\ row by row select in TC? can you run the job in debug - may be able to find out at what point the column goes missing?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 04, 2016 at 02:50 PM
0

Hi Aasavari,

thank you for the reply.

I am using cached comparison table. I can start the job in debug mode but it errors out before hitting the breakpoint just before the Table comparison.

Kind regards,

Scott

Share
10 |10000 characters needed characters left characters exceeded
Aasavari Bhave
Nov 04, 2016 at 05:18 PM
0

if you trace SQL readers - do you see any select statement or create stored proc? For Hana Reading\loading DS will create a stored proc. Does it have that column. Almost looks like something corrupted, what if you create a new datastore and import that table? Do you see the column? What datatype is it?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Nov 18, 2016 at 09:50 AM
0

Try this: remap to a different table, then go back and immidiately remap to the first table again.

(I was in a similar sitiuation where Table Comparison would not pick a change after reimport)

Share
10 |10000 characters needed characters left characters exceeded