Skip to Content

Why are my childroles not being assigned?

We are using GRC (V1100, sp14)/CUA. We have role mapping setup. When we create a new user and do our provisioning, only the Parent role gets assigned.

Audit log reads:

Request 16606 of type New Account Submitted by Diana Wetmore ( WETMORED ) for Markian Duma2 ( DUMAM2 ) with Priority Request Turn Around

Role ZS:PPM_PREPARER added to request for PMPCLNT300 ( DUMAM2 ) for action 'Assign' with validity 05/16/2018-12/31/9999

Childrole-ZS:PPM_ENDUSER role added because of role mapping to parent role to ZS:PPM_PREPARER with Validity dates 20180516-12/31/9999

Childrole-ZS:PPM_VIEWER_ADDIN role added because of role mapping to parent role to ZS:PPM_PREPARER with Validity dates 20180516-12/31/9999

Approved by WETMORED at Path PRD_PATH and Stage NOROLE
05/16/2018 09:24:28 Wetmore,Diana (WETMORED)

Role ZS:PPM_PREPARER in system PMPCLNT300 is approved for action 'Assign' with validity 05/16/2018-12/31/9999

Role ZS:PPM_ENDUSER in system PMPCLNT300 is approved for action 'Assign' with validity 05/16/2018-12/31/9999

Role ZS:PPM_VIEWER_ADDIN in system PMPCLNT300 is approved for action 'Assign' with validity 05/16/2018-12/31/9999

New User:DUMAM2 created in System(s): PMPCLNT300

DUMAM2 User does not exist in target system PMPCLNT300
05/16/2018 09:26:38 Workflow System, (WF-BATCH)

Company address cannot be selected

Auto provisioning activity at end of request at Path Z_ESCAPE and Stage GRAC_SECURITY

Role: ZS:PPM_PREPARER assigned to user:DUMAM2 in System(s):PMPCLNT300
New User:DUMAM2 created in System(s): PMPCLNT300

I have checked my Company Address and there is nothing wrong with it.

Provisioning log:

stlqe.png (26.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    May 16 at 06:16 PM

    Diana,

    I guess you are referring to mapped roles not derived roles(enabler),I hope the following SAP Note will fix your issue

    2629405 - Mapped roles are not getting provisioned

    Thanks

    Ramesh

    Add comment
    10|10000 characters needed characters exceeded

  • May 21 at 01:24 PM

    Hi Diana,

    I faced a similar issue in my non-prod landscape where CUA was enabled. Have you performed "Maintain CUA Settings" in the User Provisioning section of SPRO? Even if you are not intending to have the CUA system provision the roles, you need to maintain the CUA Global System in their and simply check/uncheck the Active box for the entry. In my case, I needed to add the CUA Global System and leave the Active box unchecked.

    -Ken

    Add comment
    10|10000 characters needed characters exceeded