Skip to Content
0

Error: Method 'GET_ENTITY' not implemented in data provider class in OData extension

May 16 at 04:26 PM

281

avatar image

Hi @Andre Fischer,

Overview of the error like why or how this error came. We have a requirement that our client wants to allow employee to fill timesheet as per the quota left. for that what we done is, we extended the standard OData service and created one entityset to bring the quota available under 'Data Model'. when we are trying to implement 'service implementation' for the entityset it was not allowing since it took the reference of standard OData service. for that we implemented the entityset in the standard methods of

/IWBEP/IF_MGW_APPL_SRV_RUNTIME~GET_ENTITY

/IWBEP/IF_MGW_APPL_SRV_RUNTIME~GET_ENTITYSET

after implementing we generated run-time artifacts and it is successful.

After that we tried to run the request URI for entityset from gateway client then we are got this error.

This below link is reference of this issue,

Mapping not allowed. The model in project ZGW_HCM_MYTIMESHEET_X is redefining another

Thank you Andre Fischer. please help me on thismethod-get-entity-not-implemented-in-data-provider.png

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Kiran VK May 16 at 05:16 PM
0

Thank you Andre Fischer, we found the issue and fixed it. the issue was Entityset was missing in the standard method.

Share
10 |10000 characters needed characters left characters exceeded