Skip to Content
0

Unable to locate the HANA DI server

May 16 at 09:09 AM

108

avatar image

while enabling tenant DB for XSA v1.0.63 i am encountering the following error

Error during (un-)registering logical database 'DE1': Fatal error occurred during installation: FAILED to create container group: [129]: transaction rolled back by an internal error: "_SYS_DI"."CREATE_CONTAINER_GROUP": line 11 col 3 (at pos 298): transaction rolled back by an internal error: Unable to locate the HANA DI server

HDB version is 2.00.020.00.1500920972 (fa/hana2sp02)

Kindly help !

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Michael Healy
May 16 at 04:04 PM
0

I see your SID here is called DE1. You have mentioned in the ticket you can see a DI server on your DEV and another system....so from what I see there is no DI server in your DE1 system.

Did you ever remove the DISERVER? It should be there.

Have you tried adding the DI service manually?

ALTER SYSTEM ALTER CONFIGURATION ('daemon.ini', 'host', '<host name>') SET ('diserver','instances') WITH RECONFIGURE

ALTER SYSTEM ALTER CONFIGURATION ('topology.ini', 'system') SET ('/host/<host name>', 'diserver') WITH RECONFIGURE

ALTER SYSTEM ALTER CONFIGURATION ('topology.ini', 'system') SET ('/volumes', '<volume_id>') WITH RECONFIGURE

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Michael,

Thanks for your reply.

Our current HDB version is 2.00.020.00.1500920972 (fa/hana2sp02) MDC where we have one tenant, say DE1

While enabling tenant DB for XSA v1.0.63 i am encountering the following error

Error during (un-)registering logical database 'DE1': Fatal error occurred during installation: FAILED to create container group: [129]: transaction rolled back by an internal error: "_SYS_DI"."CREATE_CONTAINER_GROUP": line 11 col 3 (at pos 298): transaction rolled back by an internal error: Unable to locate the HANA DI server

I tried notes search for the above issue but not luck for us.

I have not removed or disabled any existing diserver.

But Yes I tried adding manually the diserver for tenant DB,Based on the error : Unable to locate the HANA DI server , I was thinking that we needed diserver for tenant DB DE1 by using sql "ALTER DATABASE DE1 ADD 'diserver'" , service got added but it is not getting started.

this is the result of sapcontrol command for diserver services.

hdbdiserver, HDB Deployment Infrastructure Server, GREEN, Running, 2018 05 12 09:03:27, 103:07:01, 7498 hdbdiserver, HDB Deployment Infrastructure Server-DEV, GREEN, Running, 2018 05 12 09:03:28, 103:07:00, 7502 hdbdiserver, HDB Deployment Infrastructure Server-DE1, RED, Stopped, , , -1

Our major task is enable tenant for XS Advanced , once it is enabled we will map some spaces to tenant DB and teamc can start work.

Request your support here where we missed

Thanks and Regards

Sampath R.

0

Ok, I would remove the DiServer to get it started and then add it after. same SQL as above but change SET with UNSET. It looks as though you have hit a bug here.

Can generate a full system info dump from OS and paste the crash stack here?

0

Hi Michael,

I generated the full system info dump which of close to 60 MB (including systemDB and tenant DB).

Could you please help me how I can send the dump to you?

Between I executed this query for tenant DB and it worked.

ALTER SYSTEM ALTER CONFIGURATION ('topology.ini', 'system') UNSET ('/host/hana-1.dev.ei.pwcinternal.com/diserver', '30052') WITH RECONFIGURE

Many thanks for your support.

Thanks and Regards

Sampath R.

0
Thomas Jung
May 16 at 12:14 PM
0

You should enter a support ticket.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Thomas,


This is the incident number : "235132 / 2018 Hana MDC XSA setup"

No solution has been provided by SAP.

Do you have any solution for the same.

0