Skip to Content

Crystal Report 2016 SP5 OP2 connection with BI 4.2 SP5

I am having issue when connecting CR designer 2016 SP5 with BI 4.2 SP5

The issue is when trying to connect to BO server CR designer fails most of the time like 8 out of 10.

It seldom connect, please advise steps to troubleshoot this issue.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • May 15 at 09:00 PM

    Thanks Dell for quick reply,

    Here is the information

    * SAP BusinessObjects BI platform 4.2 SP5 Patch 2 update

    * SAP Crystal Reports 2016 SP5 Patch 2 update

    Add comment
    10|10000 characters needed characters exceeded

  • May 15 at 09:08 PM

    attached herewith a snapshot from BO

    Add comment
    10|10000 characters needed characters exceeded

  • May 15 at 08:45 PM

    Is your BOBJ on the same patch of 4.2 SP5 as your Crystal is? They need to be at the same patch level.

    -Dell

    Add comment
    10|10000 characters needed characters exceeded

  • May 15 at 08:48 PM

    Crystal Reports selects port numbers randomly to connect to Central Management Server. Some of the ports could be blocked by firewall. It would explain the 8 out of 10 statistic. One of the solution is to hardcode the port number on the server or configure firewall.

    Add comment
    10|10000 characters needed characters exceeded

  • May 15 at 10:29 PM

    Here is what I would suggest:

    1. Download TCPView utility from here:

    https://docs.microsoft.com/en-us/sysinternals/downloads/tcpview

    2. Close all unused applications

    3. Start TCPView utility

    4. Open Crystal Reports window and have it side by side with TCPView

    5. In TCPView scroll to see crw32.exe lines

    6. Try to login from CR to Server

    TCPView should tell you if Connection established or not and what Port number used.

    Then request your IT to open the ports range for CR.

    There are many firewalls applications and setting are different for each one.

    Add comment
    10|10000 characters needed characters exceeded

  • May 18 at 02:07 PM

    Hi Vitaly,

    Thanks for your cooperation.

    I checked your suggestion with ProcessExplorer tool and attached herewith the information, in TCP/P section it did say connection established but CR just spinning spinning...and spinning see attached screenshot from CR as well.

    cr-hanginig.png processexplorer-cr-snapshot.png


    Add comment
    10|10000 characters needed characters exceeded

  • May 22 at 02:03 PM

    Hi SAP Crystal Report Support team,

    Can someone look this issue in your team? or anyone else from forum????/


    Thanks,

    Syed

    Add comment
    10|10000 characters needed characters exceeded