Skip to Content
avatar image
Former Member

AdHoc Approver don't show up when using BADI-WF (WS14000133)

Hi Gyus,

I'm developing an approval process with the n-step BADI Approval WF (WS14000133) on an SRM 5.5 One-Client System (BE is ERP6.0).

Everything works fine so far, defining several approval steps, realising already approver levels, having multiple approvers in one step, etc.

Now I tested the functionality of adding an adhoc approver. Unfortunately this doesn't work because in the next round-trip this approver doesn't show up. But it is also not passed into the BADI so that I can remember this approver. Might this be a problem of the WFL security level of the user who addes this adhoc approver?

Does anyone of you have an idea or hint?

Kind regards,

Thomas

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Nov 22, 2008 at 08:45 PM

    Hi,

    Manage BBP_WFL_SECURITY parameter (personalisation on user or role, or with BADI)

    4 level possible:

    Level 4 (High) - SC modification during approval possible + WF continues

    Level 3 (medium) - SC modification during approval possible + WF restarts if starting condition targets a new WF

    Level 2 (low) - SC modification during approval possible + WF restarts

    Level 1 (no) - SC modification during approval not possible

    As soon as your WF restarts or changes the adhoc agents are reset

    Also Have a look at these notes:

    Note 1127341 - Added Approver/Reviewer disappear on screen refresh

    Note 1175341 - document creator cannot add adhoc approver in shop-for case

    Note 423112 - Determining the processor assignment in an insertable step

    Note 414928 - 'Add approver' works wrong when second approver not found

    Note 382393 - Add approver/reviewer in Approval Preview

    If the prob still persists,open a ticket at SAP OSS.

    BR,

    Disha.

    Add comment
    10|10000 characters needed characters exceeded