Skip to Content
0
Former Member
Nov 22, 2008 at 12:54 PM

Result Recording QE11

38 Views

DATA: BEGIN OF ichar_results OCCURS 0.

INCLUDE STRUCTURE bapi2045d2.

DATA: END OF ichar_results.

DATA: BEGIN OF isingle_results OCCURS 0.

INCLUDE STRUCTURE bapi2045d4.

DATA: END OF isingle_results.

DATA: BEGIN OF bapireturn2 OCCURS 0.

INCLUDE STRUCTURE bapiret2.

DATA: END OF bapireturn2.

DATA: BEGIN OF i_inspointdata .

INCLUDE STRUCTURE bapi2045l4.

DATA: END OF i_inspointdata.

DATA: BEGIN OF i_returntable OCCURS 0.

INCLUDE STRUCTURE bapiret2.

DATA: END OF i_returntable.

i_inspointdata-userc1 = '8A032921'.

i_inspointdata-userd1 = sy-datum.

i_inspointdata-usert1 = sy-uzeit.

ichar_results-insplot = '890000000160'.

ichar_results-inspoper = '0010'.

ichar_results-inspchar = '0010'.

ichar_results-closed = 'X'.

ichar_results-evaluated = 'X'.

ichar_results-evaluation = 'A'.

ichar_results-mean_value = '0.1'.

APPEND ichar_results.

CALL FUNCTION 'BAPI_INSPOPER_RECORDRESULTS'

EXPORTING

insplot = '890000000160'

inspoper = '0010'

insppointdata = i_inspointdata

IMPORTING

return = bapireturn2

TABLES

char_results = ichar_results

  • single_results = isingle_results

returntable = i_returntable.

CALL FUNCTION 'BAPI_TRANSACTION_COMMIT'

EXPORTING

wait = 'X'

IMPORTING

return = bapireturn2.

The mean value is not getting recorded although an inspection point gets assigned everytime I run this code. Could any one guide me as to how do I get the results recorded?

Edited by: Vishal Bhatia on Nov 22, 2008 6:24 PM