Skip to Content
avatar image
Former Member

Read Only Field in Qualified Flat Table

Hi Guys.

After upgrading MDM 5.5 SP4 to MDM 5.5 SP6, fields of the qualified flat table appear as read only in Standard IView Item Details.

Any ideas ?

Thanks in advance

Luciano

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Nov 24, 2008 at 02:24 AM

    Hi Luciano,

    Have you made sure to upgrade your portal content as well when you upgraded your MDM ?

    As portal SCA files are MDM server version and patch dependent.

    So if you have upgraded to SP06 from SP04 then accordingly you will have to deploy the SP06 version sca files on WAS.

    This will also cause you to recreate your Iviews and pages again as once you undeploy your older version of Sca file from EP their Iview contents and configurations will also be lost.Unless you have used some way of reusing the created iViews.

    So test for these two changes,they could be the possible cause of the qualified fields behaviour.

    Also make sure you upload the rep with update indices and Update repository if you are using an archived version of it from the SP04 version to the SP06 version.

    Hope It Helped

    Thanks & Regards

    Simona Pinto

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Simona,

      The Portal content was not updated, only Standard IViews , the archives MDMJAVAAPI06_3.sca, BPMDMTECHN06_3.sca and BPMDMAPPLI06_3.sca files were loaded correctly.

      All IViews are correct, working, but editing the qualified field is not possible, even marked the property updatable = true;

      The IViews and Pages were not recreated, but working.

      I create a new iVIEW can not edit the qualified field.

      [View the Picture|http://www.harepix.com/images/860130777.jpg]

      Thanks

      Luciano Feletti Aponte

  • avatar image
    Former Member
    Nov 25, 2008 at 03:51 AM

    Hi Luciano,

    I think you want to edit the qualified table while creating the new record. If this is the case then this the proper behavior because you cannot add entries in the qualified table unless you save the main table records. When you want to create new record, first fill all the main table fields(except qualified) and save it. Once you get the message Record Added Successfully then open the record for Editing and now you can enter data into qualified table. Compare the behavior with that of Data Manager. IN which first we create the main table record and then go into the qualified table.

    Regards,

    Jitesh Talreja

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 06, 2009 at 04:45 AM

    Hi Luciano,

    I think you are dealing with a permissions issue here. I have the same problem with Qualified fields popup and I am able to edit these fields in the popup when I logon to the Portal using a system_admin_role account.

    I'm working on setting up the security zone propperly, I'll let you know if I find something.

    Regards,

    Boris

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 06, 2009 at 03:42 PM

    OK guys,

    Here is the solution. The reason for having the Qualified fields in the portal as read-only is that in the MDM Console you have the Qualified tables for the role you are using as Read-only.

    You have to set the whole Qualified table for the role you are using a Read/Write table as the Qualified fields are being saved in this table, not only the field of your main table.

    This would enable the iView to show the Qualified field popup as editable.

    Best regards,

    Boris

    Add comment
    10|10000 characters needed characters exceeded