Skip to Content
0
Former Member
Nov 21, 2008 at 10:06 AM

Parameter Dialog missing Text Box

16 Views

The report I'm working on is about 30MB in size and contains approximately 80 sub reports. Each report or subreport points to an Oracle procedure and the report works correctly. I now need to change the report to point to a new version of each procedure. Eventually the new versions will have different functionality but right now they should be identical replacements.

I have done this on other reports (using Set Data Source Location to repoint it at the new procedure, then Database Expert to rename the table name) it has worked fine.

There is the same parameter field on each report, with the main report prompting the user and the subreports getting the value through subreport links.

When I replace the procedure in this report it results in the parameter dialog box losing the text box - there is only the null value tickbox. I've tried removing the subreport links but this doesn't seem to make a difference. I'm also unable to delete or modify any of the parameter fields.

Any idea what I might need to look at? As you can imagine I'd like to avoid rebuilding as much of the report as possible. I'm using Crystal Repots 10 with SP6 (although the same symptoms also occured before applying the service pack).