Skip to Content
avatar image
Former Member

Swpm failed in selftest with error code 3

Hello,

I have redhat Linux 7.5 installed on VMware. Now I am trying to install solution manger but swpm is failing in selftest with error code 3. I have set the ip and host name in /etc/hosts file. still no same error. any help would appreciated. I followed snote

2415511, 2591258. no help.

INFO 2018-05-12 12:30:05.809 (root/sapinst) (SelftestOutput) [SLPSelftestHandler.cpp:179] SLPSelftestHandler::doOutput()
Selftest output:
Connecting to: h ttps://saplab1.padda.com.padda.com:4237
executing: GET /sapinst/slp/whoami HTTP/1.1
java.net.UnknownHostException: saplab1.padda.com.padda.com: Name or service not known
Exit code: 3
TRACE 2018-05-12 12:30:05.809 (root/sapinst) (SelftestOutput) [CThrThread.cpp:137] CThrThread::threadFunction()
Thread SelftestOutput (140227586811648) returns with 0
TRACE 2018-05-12 12:30:05.809 (root/sapinst) (startInstallation) [syuxctask.cpp:437] CUnixProcessManager::sap_waitpid()
Child process 15031 returned 3
TRACE 2018-05-12 12:30:05.809 (root/sapinst) (startInstallation) [CThrThread.cpp:246] CThrThread(SelftestOutput)::join()
Joined thread SelftestOutput (140227586811648), returning 0
INFO 2018-05-12 12:30:05.809 (root/sapinst) (startInstallation) [SLPSelftestHandler.cpp:169]
********************************************************************************
ERROR in Selftest. Return code: 3

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    May 15 at 06:14 PM

    Hi,

    You need to correct a line in the /etc/hosts file.

    Delete this:

    192.168.122.1 saplab1 padda.com

    And add this:

    192.168.122.1 saplab1.padda.com saplab1

    Check if that helps :-)

    Add comment
    10|10000 characters needed characters exceeded

  • May 13 at 01:02 PM

    Look at the line:

    Connecting to: h ttps://saplab1.padda.com.padda.com:4237
    

    There is something wrong with your hostname (double padda.com).

    Please paste the results of:

    a) OS Command: hostname -f

    b) OS Command: hostname -s

    c) The content of file /etc/hosts

    d) Print screen of Network Settings -> Hostname/DNS

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 15 at 05:18 PM

    Hello Bartosz,

    Thanks for reply. details are below.

    [root@saplab1 ~]# hostname -f
    saplab1.padda.com
    [root@saplab1 ~]# hostname -s
    saplab1
    [root@saplab1 ~]#

    ---------------------------------------------------------------------

    127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6i
    192.168.122.1 saplab1 padda.com

    ----------------------------------------------------------------------

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 22 at 03:05 PM

    Hello Bartosz,

    Thanks for your help.

    Second mistake I found was I have given host name as full domain name. I have given host name as "saplab1.padda.com" instead of "saplab1"

    now both host and etc/hosts file issue resolved. I have started swpm :)

    Thanks for your help

    Add comment
    10|10000 characters needed characters exceeded