Skip to Content

disp+work.EXE "stopped" - DB-Connect Failed 008192

When I try to bring up my SAP system, I get in the process list: disp+work.EXE "stopped", and in the Syslog, Initialization DB-Connect Failed Return Code 008192

dev_w0 contains:

---------------------------------------------------
trc file: "dev_w0", trc level: 1, release: "700"
---------------------------------------------------
*
*  ACTIVE TRACE LEVEL           1
*  ACTIVE TRACE COMPONENTS      all, MJ
*
B  
B Thu Nov 20 22:18:00 2008
B  create_con (con_name=R/3)
B  *** ERROR => Invalid profile parameter dbms/type (or environment variable dbms_type) = <undef>, cannot load DB library
 [dbcon.c      4537]
M sysno      00
M sid        DS1
M systemid   562 (PC with Windows NT)
M relno      7000
M patchlevel 0
M patchno    144
M intno      20050900
M make:      multithreaded, Unicode, 64 bit, optimized
M pid        4000
M 
M  kernel runs with dp version 232000(ext=109000) (@(#) DPLIB-INT-VERSION-232000-UC)
M  length of sys_adm_ext is 576 bytes
M  ***LOG Q0Q=> tskh_init, WPStart (Workproc 0 4000) [dpxxdisp.c   1305]
I  MtxInit: 30000 0 0
M  DpSysAdmExtCreate: ABAP is active
M  DpSysAdmExtCreate: VMC (JAVA VM in WP) is not active
M  
M Thu Nov 20 22:18:01 2008
M  DpShMCreate: sizeof(wp_adm)		25168	(1480)
M  DpShMCreate: sizeof(tm_adm)		5652128	(28120)
M  DpShMCreate: sizeof(wp_ca_adm)		24000	(80)
M  DpShMCreate: sizeof(appc_ca_adm)	8000	(80)
M  DpCommTableSize: max/headSize/ftSize/tableSize=500/16/552064/552080
M  DpShMCreate: sizeof(comm_adm)		552080	(1088)
M  DpSlockTableSize: max/headSize/ftSize/fiSize/tableSize=0/0/0/0/0
M  DpShMCreate: sizeof(slock_adm)		0	(104)
M  DpFileTableSize: max/headSize/ftSize/tableSize=0/0/0/0
M  DpShMCreate: sizeof(file_adm)		0	(72)
M  DpShMCreate: sizeof(vmc_adm)		0	(1864)
M  DpShMCreate: sizeof(wall_adm)		(41664/36752/64/192)
M  DpShMCreate: sizeof(gw_adm)	48
M  DpShMCreate: SHM_DP_ADM_KEY		(addr: 0000000010E70050, size: 6348592)
M  DpShMCreate: allocated sys_adm at 0000000010E70050
M  DpShMCreate: allocated wp_adm at 0000000010E72150
M  DpShMCreate: allocated tm_adm_list at 0000000010E783A0
M  DpShMCreate: allocated tm_adm at 0000000010E78400
M  DpShMCreate: allocated wp_ca_adm at 00000000113DC2A0
M  DpShMCreate: allocated appc_ca_adm at 00000000113E2060
M  DpShMCreate: allocated comm_adm at 00000000113E3FA0
M  DpShMCreate: system runs without slock table
M  DpShMCreate: system runs without file table
M  DpShMCreate: allocated vmc_adm_list at 000000001146AC30
M  DpShMCreate: allocated gw_adm at 000000001146ACB0
M  DpShMCreate: system runs without vmc_adm
M  DpShMCreate: allocated ca_info at 000000001146ACE0
M  DpShMCreate: allocated wall_adm at 000000001146ACF0
M  ThTaskStatus: rdisp/reset_online_during_debug 0
X  EmInit: MmSetImplementation( 2 ).
X  MM global diagnostic options set: 0
X  <ES> client 0 initializing ....
X  Using implementation view
X  <EsNT> Using memory model view.
M  <EsNT> Memory Reset disabled as NT default
X  ES initialized.
M  ThInit: running on host SecureBI
M  
M Thu Nov 20 22:18:02 2008
M  calling db_connect ...
B  create_con (con_name=R/3)
B  *** ERROR => Invalid profile parameter dbms/type (or environment variable dbms_type) = <undef>, cannot load DB library
 [dbcon.c      4537]
M  ***LOG R19=> ThInit, db_connect ( DB-Connect 008192) [thxxhead.c   1440]
M  in_ThErrHandle: 1
M  *** ERROR => ThInit: db_connect (step 1, th_errno 13, action 3, level 1) [thxxhead.c   10468]
M  
M  Info for wp 0
M  
M    stat = WP_RUN
M    waiting_for = NO_WAITING
M    reqtype = DP_RQ_DIAWP
M    act_reqtype = NO_REQTYPE
M    rq_info = 0
M    tid = -1
M    mode = 255
M    len = -1
M    rq_id = 65535
M    rq_source = 
M    last_tid = 0
M    last_mode = 0
M    semaphore = 0
M    act_cs_count = 0
M    csTrack = 0
M    csTrackRwExcl = 0
M    csTrackRwShrd = 0
M    mode_cleaned_counter = 0
M    control_flag = 0
M    int_checked_resource(RFC) = 0
M    ext_checked_resource(RFC) = 0
M    int_checked_resource(HTTP) = 0
M    ext_checked_resource(HTTP) = 0
M    report = >                                        <
M    action = 0
M    tab_name = >                              <
M    attachedVm = no VM
M  
M  *****************************************************************************
M  *
M  *  LOCATION    SAP-Server SecureBI_DS1_00 on host SecureBI (wp 0)
M  *  ERROR       ThInit: db_connect
M  *
M  *  TIME        Thu Nov 20 22:18:02 2008
M  *  RELEASE     700
M  *  COMPONENT   Taskhandler
M  *  VERSION     1
M  *  RC          13
M  *  MODULE      thxxhead.c
M  *  LINE        10688
M  *  COUNTER     1
M  *
M  *****************************************************************************
M  
M  PfStatDisconnect: disconnect statistics
M  Entering TH_CALLHOOKS
M  ThCallHooks: call hook >ThrSaveSPAFields< for event BEFORE_DUMP
M  *** ERROR => ThrSaveSPAFields: no valid thr_wpadm [thxxrun1.c   724]
M  *** ERROR => ThCallHooks: event handler ThrSaveSPAFields for event BEFORE_DUMP failed [thxxtool3.c  261]
M  Entering ThSetStatError
M  ThIErrHandle: do not call ThrCoreInfo (no_core_info=0, in_dynp_env=0)
M  Entering ThReadDetachMode
M  call ThrShutDown (1)...
M  ***LOG Q02=> wp_halt, WPStop (Workproc 0 4000) [dpnttool.c   327]

dev_ms contains

---------------------------------------------------
trc file: "dev_ms", trc level: 1, release: "700"
---------------------------------------------------

[Thr 4040] Thu Nov 20 22:17:55 2008
[Thr 4040] MsSSetTrcLog: trc logging active, max size = 20971520 bytes
systemid   562 (PC with Windows NT)
relno      7000
patchlevel 0
patchno    137
intno      20050900
make:      multithreaded, Unicode, 64 bit, optimized
pid        2304

[Thr 4040] ***LOG Q01=> MsSInit, MSStart (Msg Server 1 2304) [msxxserv.c   1832]
[Thr 4040] load acl file = D:\usr\sap\DS1\SYS\global\ms_acl_info.DAT
[Thr 4040] MsGetOwnIpAddr: my host addresses are :
[Thr 4040]   1 : [7.12.27.65] SecureBI (HOSTNAME)
[Thr 4040]   2 : [127.0.0.1] SecureBI (LOCALHOST)
[Thr 4040]   3 : [192.168.0.195] SecureBI.hsd1.ca.comcast.net. (NILIST)
[Thr 4040] MsHttpInit: full qualified hostname = SecureBI
[Thr 4040] HTTP logging is switch off
[Thr 4040] set HTTP state to LISTEN
[Thr 4040] ms/icf_info_server : deleted
[Thr 4040] *** I listen to port sapmsDS1 (3600) ***
[Thr 4040] *** I listen to internal port 3900 (3900) ***
[Thr 4040] *** HTTP port 8100 state LISTEN ***
[Thr 4040] CUSTOMER KEY: >B1755972297<

[Thr 4040] Thu Nov 20 22:19:07 2008
[Thr 4040] *** ERROR => MsSClientHandle: no server provides service ENQ  (4), requested from SecureBI_DS1_00 [msxxserv.c   4684]

[Thr 5108] Thu Nov 20 22:25:58 2008
[Thr 5108] MsSSoftShutdown: received SIGQUIT (3), start softshutdown phase
[Thr 5108] set HTTP state to CLOSED
[Thr 5108] MsHttpPortRemoveIdx: removed ms/server_port_0=PROT=HTTP,PORT=8100,TIMEOUT=20,PROCTIMEOUT=60 (1)
[Thr 5108] *** HTTP port 8100 state CLOSED ***
[Thr 5108] MsSCheckShutdown: no more clients connected
[Thr 5108] ***LOG Q02=> MsSHalt, MSStop (Msg Server 2304) [msxxserv.c   5949]

The db instance seems to be ok. The only error I can find there is "ERR 18431 MESSAGES Cannot write to event log rc=5".

It was all working fine a couple of days ago, and as far as I can tell ⚠️ I've not changed anything.

matt

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Nov 21, 2008 at 07:39 AM

    Hi Matt,

    there is another error message in dev_w0:

    B  *** ERROR => Invalid profile parameter dbms/type (or environment variable dbms_type) = <undef>, cannot load DB library
     [dbcon.c      4537]
    

    Basically this means that you've forgotten to set the DBMS_TYPE environment variable in the SAPService<SID> environment.

    Set it to DBMS_TYPE=ADA and the problem should be gone.

    regards,

    Lars

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Matthew Billingham

      on windows you can set the parameter as --> my computer --> right click --> advance --> environment variables

      cheers,

      -Sunil

  • avatar image
    Former Member
    Nov 26, 2008 at 04:03 PM

    I have had exactly the same problem on a PI 7.0 system. It stopped, just after a reboot. I still don't know what has changed on the configuration, but it was solved after adding the dbms_type parameter in Windows environment. I'm still puzzled. If anyone has more information on this, I'd appreciate it.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Martin,

      have you added the paramter to the environment of the SAPSERVICE<SID> user?

      It's really easy to be mistaken on WIndows here, since you usually never logon as SAPSERVICE<SID>...

      regards,

      Lars

  • avatar image
    Former Member
    Nov 26, 2008 at 04:18 PM

    Actually, no I didn't. It's a general environment variable now. I'll check if it is there if I log on as Service<sid>. Still don't know what has caused the problem though, it ran fine and nobody has tempered with anything, just like the topicstarter.

    Edit:

    I tried to check it, but cannot log on with SAPService<sid>. I logon to my servers with RDP and this account is specifically denied logon through terminal server by a policy. I'm to lazy to set up a monitor so I just leave it this way 😊

    Edited by: Martin Loohuizen on Nov 27, 2008 9:12 AM

    Add comment
    10|10000 characters needed characters exceeded