Skip to Content
0

SAP Netweaver 7.51 abap developer edition install failed

May 12 at 07:08 PM

286

avatar image
Former Member

I am trying to install sap_netweaver_as_abap_751_sp02_ase_dev_edition on Linux, but failing continuously... I am using following blog post for this: Installing ABAP AS 751 SP02 on Linux

I run the installation, by entering the command ./install.sh and getting following error:

Execute step checkSybaseUser of component |offlineadjustment_dialogs|ind|ind|ind|ind|0|0|offlineadjustment_os_users|ind|ind|ind|ind|osUsers|0|NW_GetDBUserParameter|ind|ind|ind|ind|getDBUserParameter|0|NW_GetUserParameterUnix_syb|ind|ind|ind|ind|syb_unix|0
ERROR 2018-05-12 20:38:59.057 (root/sapinst) id=modlib.jslib.caughtException errno=MUT-03025
Caught ESAPinstException in module call: Validator of step |offlineadjustment_dialogs|ind|ind|ind|ind|0|0|offlineadjustment_os_users|ind|ind|ind|ind|osUsers|0|NW_GetDBUserParameter|ind|ind|ind|ind|getDBUserParameter|0|NW_GetUserParameterUnix_syb|ind|ind|ind|ind|syb_unix|0|checkSybaseUser reports an error: 

To solve that problem start the installation without using SAPINST_START_GUI option..

sapinstlog.txt

how to fix this error message?

I am using Win10 and installing ABAP on Oracle Virtualbox(OpenSUSE 64-bit)

sapinstlog.txt (45.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Bartosz Jarkowski May 13 at 12:59 PM
0

Please paste results of:
a) OS Command: hostname -f

b) OS Command: hostname -s

c) The content of file /etc/hosts

d) Print screen of Network Settings -> Hostname/DNS

Show 12 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi,

here are the results:

Network Settings -> Hostname/DNS

Network Settings -> Global Options

0

You haven't provided the domain name and that's why you're getting the error.

Enter domain name in the Network Settings (dummy.nodomain).

Also, your file /etc/hosts should include following line:

<your IP> vhcalnplci.dummy.nodomain vhcalnplci

0
Former Member

Network Settings -> Global Options

0
Former Member

/etc/hosts

hosts.png (21.3 kB)
0

It looks OK - don't forget to update the domain field in Network Settings -> Hostname/DNS

0
Former Member

I put dummy.nodomain in domain name field and save it. But when I open it is deleted. Always getting the same error in Crash Reports

0

I have a feeling this may be caused by empty DNS Servers in Hostname/DNS. You should update the settings with your DNS configuration (or put for example 8.8.8.8).

Then update the domain field again and save the settings. Let us know the results!

Good luck!

0
Former Member

I'm sorry, I don't quite understand what you mean by "update the settings with your DNS configuration (or put for example 8.8.8.8)." Can you tell me more exactly? Thanks!

0

Put 8.8.8.8 in field Name Server 1 on DNS/Hostaname screen.

Then type your domain and save the settings

0
Former Member

Still, I am getting the same error.

In crash report:

....

Unable to determine parameter "DNS domain name". DNS domain name is not configured in resolv.conf (unix) or the registry (Windows) and neither getaddrinfo nor gethostbyname could retrieve it

...

I find same issues here 2502022 - SWPM fails with error 'Unable to determine parameter "DNS domain name"', but I don't have access

0

What does hostname -f? Also, did the domain name save?

I tried to open the SAP Note, but it says it’s removed.

0
Former Member

Output of hostname -f is vhcalnplci and a domain name is still not saved

0
Maxim Schibnev May 12 at 07:49 PM
0

You can try this guide: https://dalanzg.github.io/tips-tutorials/sap/2017/11/09/how-to-install-sap-netweaver-751-sp02-as-abap-developer-edition-in-opensuse/. At first glance, they are similar, but, perhaps, there will be some differences.

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Maxim,

The problem still occurs. If I run with -g option, getting following error:

SAPCAR: processing archive /home/developer/netweaver/server/TAR/x86_64/SWPM10SP20_4-20009701.SAR (version 2.01)
SAPCAR: 1593 file(s) extracted
[==============================] \ extracting... done!

SAPinst build information:
--------------------------
Version: 749.0.28
Build: 1770975
Compile time: Jul 05 2017 - 13:39:50
Make type: optU
Codeline: 749_REL
Platform: linuxx86_64
Kernel build: 749, patch 300, changelist 1770269
SAP JRE build: SAP Java Server VM (build 8.1.030 25.51-b02, Apr 26 2017 16:01:22 - 81_REL - optU - linux amd64 - 6 - bas2:288514 (mixed mode))
SAP JCo build: 3.0.16
SL-UI version: 2.6.2
SAP UI5 version: 1.42.4
Exe directory: /tmp/sapinst_exe.6504.1526160751

....

Downloading CRL with /tmp/sapinst_exe.6504.1526160751/jre/bin/java -Xmx512M -cp "/tmp/sapinst_exe.6504.1526160751/*" com.sap.sdt.sltoolbox.sec274.DownloadCRL "/root/.sapinst/crlbag.p7s"
A child process has been started. Pid = 6524
Started thread eventLoop (140423727732480)
Entering event loop
Started thread SLPCommunicator (140423746021120)
account user="root" uid="0" exists with parameter home="/root"
File /root/.sapinst/permfile.cfg written ok.
File /root/.sapinst/accessUserList.cfg written ok.
Unable to determine parameter "DNS domain name". DNS domain name is not configured in resolv.conf (UNIX) or the registry (Windows) and neither getaddrinfo nor gethostbyname could retrieve it.

Exception thrown near line 228 in file /bas/749_REL/bc_749_REL/src/ins/SAPINST/impl/src/syslib/network/syxxcnwmgt.cpp
At line 228 file /bas/749_REL/bc_749_REL/src/ins/SAPINST/impl/src/syslib/network/syxxcnwmgt.cpp
Call stack:
/bas/749_REL/bc_749_REL/src/ins/SAPINST/impl/src/baselib/CThrThread.cpp: 73: CThrThread()::staticThreadFunction()
/bas/749_REL/bc_749_REL/src/ins/SAPINST/impl/src/baselib/CThrThread.cpp: 80: CThrThread(SLPCommunicator)::threadFunction()
/bas/749_REL/bc_749_REL/src/ins/SAPINST/impl/src/guiengine/CSLPCommunicationServer.cpp: 100: CSLPCommunicationServer::doWork()
/bas/749_REL/bc_749_REL/src/ins/SAPINST/impl/src/syslib/network/syxxcnwmgt.cpp: 144: iastring CSyNetworkMgtImpl::getDNSDomainName() const

Unable to determine parameter "DNS domain name". DNS domain name is not configured in resolv.conf (UNIX) or the registry (Windows) and neither getaddrinfo nor gethostbyname could retrieve it.
Failed action: with parameters
Error number 301 error type SPECIFIC_CODE

errorlog.txt

errorlog.txt (5.2 kB)
0

In my case, I didn't install any GUI at all.
And one more difference from the manual. I setup VM network to network bridge to my home router (in this case you should bypass port forwarding setup). At the router I assign static IP (in a DHCP section) to vhcalnplci host.

You should try this. It worked for me. And make sure you specified the correct ip for vhcalnplci in /etc/hosts of a guest system.

0
Former Member

Hi Maxim,

I set a hostname for a specific static IP but occurs again the same error.


1.png (40.4 kB)
0