Skip to Content

SAP HANA Streaming Analytics Run Time - No authorization for DataServices

Hello Experts

I have got my SAP HANA Express edition latest 2.0 up and running in google cloud platform. After that i have installed Streaming Analytics server successfully. Finally I am able to connect my eclipse to both(i have installed plugins in eclipse).I am able to create my streamserver project by I am facing two issues as of now one from eclipse and one from SAP Web ide for HANA

Issues Facing

  • Whenever i tried to test in my eclipse the streaming application it throws me an error as below.

  • When even i am building my Analytics module only in SAP Web IDE containing i get below mentioned error

What i have tried.

  • I have added Streaserver analytics role to Role collection so that XSA_ADMIN has full rights in XSA Admin cockpit.
  • Read the project logs and trace file to look for hints where i have got none.
  • Looked in Managing Streamserver/Cluster/permissions/configuration to see if something is missed from my end but all looks okay.

Any help here will be appreciated.

Thanks

Nabheet

capture.png (24.9 kB)
capture.png (14.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    May 11 at 08:59 PM

    I'll focus on the HANA Studio connection for you. When configuring the connection to the streaming server from HANA Studio, the default connection Protocol is Native as opposed to Web Services.

    (Protocol is the line between the 2 red boxes in this screenshot)

    When using a Native connection protocol, then you need access to 3 additional TCP/IP ports for each project. By default those ports are allocated dynamically when the project is started but you have the option of choosing specific ports through the Project Configuration file. This blog discusses how to configure the project ports. https://blogs.sap.com/2015/03/27/specifying-the-command-port-to-be-used-by-a-smart-data-streaming-project/

    Note that if you continue with that approach, you would also need to configure the firewall on the Google cloud platform VM to open up the required ports for external access.


    Alternatively you can recreate your server connection from HANA Studio and select the Web Services protocol instead of the Native protocol. In that case the port to specify for the connection will be the WSP port For a default HXE install, the WSP port should be 39043.




    Add comment
    10|10000 characters needed characters exceeded