Skip to Content
0

com.sap.xi.rwb , directory, repository missing in configtool after NW 7.3 upgrade.

May 10 at 06:35 AM

43

avatar image
Former Member

Hi,

We have just updated our system to NW 7.3 from NW7.0 . The upgrade finished successfully. We started the post upgrade activities and setup the SLD from NWA> Functional Units > System Landscape Directory. The wizard is completed successfully but we are not able to access the Rwb, Rep or the Dir page. Upon analysis we found out that Java EE applications list does not include the following.

com.sap.xi.directory

com.sap.xi.repository

com.sap.xi.rwb

I checked and compared the services in our sandbox system and the above mentioned services are present there but they are missing in our current system.The services are unavailable in Java Config tool too. The upgrade process finished successfully without any errors. I don't understand how these specific services are simply missing and how can we fix this.

We are also getting an error 404 when we try to refresh CPA cache. Please help us figuring out how to access RWB and REP pages.

Thanks

Atif

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Mate Moricz
May 12 at 08:58 AM
0

Hi Atif,

an incorrect wizard (not PI related which is the cause PI applications are missing) was run after the upgrade. Please check SAP Note 1286428 - Configuration Wizard: PI Wizard Templates overview, Section "Upgrade & Update Wizards" which can help you identify what is the exact wizard you need (I'm making an assumption here based on the problem description that you have a dual-stack system so most likely SAP Note 1321868 - Configuration Wizard: PI Upgrade is the one you need).


Best regards,
Mate

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member May 14 at 05:46 AM
0

Thanks for the reply Mate.

I dont think its about the wizard anymore. The apps are not there and what ever setting I try to configure or wizard I try to run end up with the missing apps error. I rasied a message to SAP but its been 11 days and there is no reply even after excalation so Im just waiting.

Share
10 |10000 characters needed characters left characters exceeded