Skip to Content
0

RZ70 - unable to send data to SLD

May 11 at 12:44 PM

310

avatar image

Dear Experts,

we've been fighting with a nasty issue for a couple of days. After a LOT of googling, we are still stuck. There are only unclear discussions with fuzzy explanations and broken links to other discussions. So...

We are trying to connect an ABAP System - NetWeaver 7.4 SPS08 to SLD and send there the data through RZ70. On other systems (SPS15), there is a second section in RZ70, where you can directly select which RFC destination to use. However in SPS08 there is no such thing.

Even though we've configured SLDAPICUST correctly, RZ70 keeps giving an error:

Used RFC destination: SLD_UC
RFC call failed: Error when opening an RFC connection (CPIC-CALL: 'ThSAPOCMINIT', communication r

Looks like it needs registration with rfcexec. Fine !!! But how ?!? Nobody says what to run on which host specifically !!!!

I have tried on the Managed system:

rfcexec -t -a SLD_UC -g <hostname_managed_system> -x sapgw00 -> this one hangs

rfcexec -t -a SLD_UC -g <hostname_of_solman> -x sapgw00 -> this one keeps scrolling the following error:

LOCATION SAP-Gateway on host <hostname_of_solman> / sapgw00
ERROR registration of tp SLD_UC from host <hostname_managed_system> not allowed

Is this the correct location to try that ? Or I should try it on the solman host ?

I've also found that I have to set gw/acl_mode to 0. I did that on both hosts and it didn't help. However I only did a hard shutdown from SMGW on the Solman. I am afraid to do it on the other host in order to not disconnect someone working there. Please advise on what to do and ALWAYS specify on which host the corresponding action should be executed.

MANY thanks in advance!

rfc | sld | rz70 | sld_uc
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Bartosz Jarkowski May 11 at 01:30 PM
0

Please have a look at SAP Note 1727745 - RFC connection error while executing transaction RZ70.

I had a similar issue and the point 2 solved my issue. If the issue persist, please check the SAP Community, because this issue with combination with Solution Manager 7.2 was already discussed - this way you'll be able to get answer faster.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

OK GREAT !!!!! Maybe I've been too sleepy or whatever... We had a second look at the note. The parameters for hostname and gateway at the SLD settings are there, but weren't maintained. We filled them out, deleted SLD_UC and SLD_NUC and now it is FINALLY working !!! Many many many THANKS !!!!!!! We were fighting with this for more than a WEEK !!!!

0

Great for letting us know! I'm glad I could help :)

Sorry I didn't reply to your previous message, but I didn't get a notification (you have used Answer instead of Comment).

0
Symon Braunbaer May 14 at 03:29 PM
0

Hello Bartosz,

I tried to look at the note you sent me:

2. Ensure that same Gateway host and Gateway Port is maintained correctly at following location:
a) SLD UI → Administration → Setting → tab page Parameter → Section= data supplier
Parameters=GatewayHost/GatewayService.

I didn't find these parameters there. Furthermore, I think that if for the other systems it is working,
it won't be fixed for this system by changing something on the SLD...

Any further ideas please ?

Share
10 |10000 characters needed characters left characters exceeded
Yogesh Patel
May 14 at 04:16 PM
0

Hello Symon Braunbaer,

Seems that error is as below...

ERROR registration of tp SLD_UC from host <hostname_managed_system> not allowed

Did you tried disabling reloading files? : https://wiki.scn.sap.com/wiki/display/SI/Reloading+the+reginfo+-+secinfo+at+a+Standalone+Gateway

Let me know if this woks with this settings.

Can you please test your RFC and paste result here?

-Yogesh

Share
10 |10000 characters needed characters left characters exceeded