Skip to Content

Customer Master SD Archiving with FI_ACCRECV_Not able to archive General Data

Dear experts,

I am trying to archive a newly created customer (No SO, Deliveries or Invoices), which is not linked to any other partner. After blocking it (XD05) and affecting the deletion flag (XD06), I used the transaction SARA with the object FI_ACCRECV. I then created a variant, used the customer and filled the Company Code and Sales Org fields.

When executing, I was able to archive the Sales Area and the FI data, but not the General Data. The message I receive is : Customer not blocked.

Can you please help me find a solution to that? Your help will be much appreciated.

Thanks in advance.

Cheers,

Zineb

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    May 11 at 04:28 PM

    "The message is always displayed in French; whether I am connected in FR or EN"

    This looks already like an indication for a custom message, means a message coded by your own IT department.

    Do this: goto SE38, enter FI_ACCRECV_WRI , set the radio button to text elements and click display.

    Search for your french message in tab Text symbols and let me know the text number.

    Then go back to the initial screen and set the radio button to Source Code and click display. In the next screen click the binocular icon and search for this text number. Maybe you can identify whether it is standard or coded by someone in your company.

    Add comment
    10|10000 characters needed characters exceeded

    • The number of the message I receive is: 108.

      After I checked with our ABAPer, we realized that this message started appearing after an enhancement he implemented in CL_VS_SwITCH_CHECK=>CMD_VMP_CVP_ILM_SFW_01() so that it would return X in order to avoid a dump we had, apparentely the program FI_ACCREV_WRI uses a field symbol named <IT_KUNNR_BLOCK_SD> that gets populated in program ERP_CVP_I1_C_ARC0001 and that is only if CL_VS_SwITCH_CHECK=>CMD_VMP_CVP_ILM_SFW_01() is not initial.

      Can you please help us better understand the situation?

      Thank you in advance!

      Cheers,

      Zineb

  • May 11 at 09:26 AM

    Have a look at this thread. Also have a look at OSS note 1591166

    Add comment
    10|10000 characters needed characters exceeded

  • May 11 at 11:29 AM

    Is it really the message "Customer not blocked" ?

    and not eventually: "Customer is blocked for deletion"

    make sure you have no flag for deletion block set in XD06


    Add comment
    10|10000 characters needed characters exceeded

    • Dear Jürgen,

      Thanks for your input. I made sure that there is no flag for the deletion block. Please see the message I receive below: (The message is always displayed in French; whether I am connected in FR or EN).

      Thank you for your time,

      Cheers,

      Zineb

      archive-block.png (31.3 kB)