Skip to Content

SAML2 service not accessible

Hi there!

I am trying to access an oData service of Hybris Marketing in the following URL, using Chrome as browser (it is a GET).

https://myxxxxxx-api.s4hana.ondemand.com/sap/opu/odata/sap/CUAN_IMPORT_SRV/$metadata


That URL changes automatically to:

https://asmxxxxxx.accounts.ondemand.com/saml2/idp/sso/asmxxxxxx.accounts.ondemand.com


This new URL ask for log on. However, if I try to log on with a communication user it gives me a log on error message.

Moreover, I tried with a business user, however I am getting the following error after the log on.

SAML2 service not accessible

What has happened?

Calling of URL https://myxxxxxx.s4hana.ondemand.co was terminated during SAML2 processing

  • No RelayState mapping found for RelayState value oucqqrwteteoeswboredyozuctoweqdstrdtazw

  • Does someone know why this is happening? Why I cannot access the oData URL in Chrome? I have tried in the Postman, but without success either.

    Here are some links that I based to do this oData, that maybe helpful finding the issue..

    Import of Data Using OData Service CUAN_IMPORT_SRV

    Import Using OData Service CUAN_IMPORT_SRV pg 26

    Facebook Pages, Google+, and Twitter pg 21

    Optimizing Performance During OData Service Calls

    Set up the communication user on the SAP Hybris Marketing Cloud system

    Similar issue

    Thanks in advance

    Marlos Damasceno

    error-odata.png (14.7 kB)
    errorlogin.png (13.5 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Follow
    • Get RSS Feed

    1 Answer

    • Best Answer
      May 08, 2018 at 05:34 PM

      Hi,

      Can you please put "saml2=disabled" at the end of URL and then try to log in using your communication user?

      https://my30XXXXX.s4hana.ondemand.com/sap/opu/odata/sap/CUAN_IMPORT_SRV/$metadata?saml2=disabled

      Thanks

      Saurabh

      Add comment
      10|10000 characters needed characters exceeded

      • Hi Mihai,

        Sorry but I am not very much familiar with set up of API management. Hence can you pls reach out to SAP Support team to get it clarified? Also pls do post the fix on here in the same thread so that everyone is aware of it.

        Many Thanks!

        Saurabh