Skip to Content
0

Parameter 4019 is not working as expected for Repository Sync

May 07 at 10:42 PM

44

avatar image

Hello,

I setup the Parameter value for 4019 to "YES". I added couple of Business roles to the End users through GRC Access Request and in the report GRAC_CHECK_BROLE_ASSIGNMENT it correctly shows the Business roles and the SAP roles associated with it along with the system. Now, i ran the Repository Object Sync and then the report changes. Now i see the "Business to Single role relation ship does not exist" error (Exception Explanation) for the roles under Business roles and it shows the same SAP roles under system with msg "user is directly assigned to technical role".

My understanding is that if Param 4019 is set to YES then it will ignore the manually assigned roles/profiles during the role sync. But in my case, it is considering the roles that are assigned via business roles as directly assigned and showing "Business to Single role relation ship does not exist" for same roles under Business roles.

The whole reason is when i tried to remove the Business roles via access request the Business roles gets removed but the back end role is not getting removed.

Please let me know if i should change Paramter 4019 to "NO"

Thanks,

Sri.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Ramesh Vithanala May 08 at 06:50 PM
0

Hi Sri,

I am not sure what your exact question here, but will try to give a stab at it...

this is what 4019 will do, if you assign a TR role manually then it will not remove...

This parameter controls whether manual changes to role assignments and profiles done
in SU01 and SU10 on the backend system are synched to the GRC repository.

Thanks

Ramesh

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Ramesh,

I did set it as "No" in mycase and tested all role removal scenarios working fine. I will close this now.

Thank you,

Sri

0