Skip to Content
0

Phantom Field appears in report w/8 subrfeports

May 03 at 10:48 PM

17

avatar image
Former Member

I have a report where the main report has no tables. Then I add in 8 subreports.

When previewing the report, everything looks fine, but when I export to MS-Excel, a field that doesn't even exist in the main report (no tables) and cannot be found/seen/seleted, appears in the exported data. I've tried everything I can think of to get rid of it. The closest I've gotten is to squish all my data to the left so that the phantom field appears on the right as the last column. My subreports have many manual running totals, running totals and formula fields that do have the field that is phantoming in the main report.

Any ideas would be greatly appreciated.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Dell Stinnett-Christy May 04 at 01:10 PM
0

There are a number of limitations in how Crystal exports to Excel - it especially has problems with exporting subreports cleanly.

Are you seeing data that doesn't exist? Or is it just a blank column? Or is it a merged column?

Can you post a screen shot of the design view of the main report?

-Dell

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member May 03 at 10:51 PM
0

I should also mention that I have started with numerous blank reports, but the phantom field always returns.

Share
10 |10000 characters needed characters left characters exceeded