Skip to Content

Unable to create target mapping and tiles with Microsoft Surface Pro 2017

Hi, Experts

I found some issue of sapui5 when using device with touch screen.

But there're some issue that I found on my surface when I tried save to target mapping.

The issue is when i save the target mapping there's nothing happened at the first time then I tried to input value again then save and error will occurs "Cannot read property 'length' of undefined"

*I tried another browser including Firefox , IE , Chrome , Opera but results are the same.

*I tested on another device with touchscreen but there is no problem like this.

*I also disable touch screen in device manager but issue still occurs.

I'am not sure this problem cause of my surface or it's bug.

Best Regards,

01.jpg (314.8 kB)
02.jpg (378.2 kB)
03.jpg (106.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • May 07 at 03:08 PM

    Hello,

    What sapui5 library version do you have installed in your system?

    I would intall the latest available patch for your release:

    2482210 “ABAP SAPUI5 1.38 release”.

    2493450 - ABAP SAPUI5 1.44 release

    2468634 - ABAP SAPUI5 1.48 release

    2550980 - ABAP SAPUI5 1.52 release

    then clear the caches as explained in:

    2319491 - How to clean up the cache after applying changes that affect SAP Fiori apps

    Hope this helps!

    Best regards,

    Bruno

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Bruno,

      SAPUI5 Version on my system is 1.44 but I'm not sure this problem came from SAPUI5 version because I tried on another device with touchscreen (Both of Window and macOS) and It's work without error. Although upgrading have a lot of impact :(

      Best Regards,
      Kritchapon