Skip to Content
author's profile photo Former Member
Former Member

Re:Create and approve batch record first

Hi All,

I am in a situation where When I am trying to take a UD for an ispection lot,System prompts the message "Create and approve batch record first".

Please adive how to go further.As I am not able to proceed. I have checked the batch also.

But am not able to figure out what is the reason.

Please advice.

Regards,

Vivek

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 10, 2008 at 01:58 PM

    Hi Vivek,

    Are your material is supposed to be batch managed????

    Actually the "Batch Management" is activated for this material (check material Master) and somehow the batch is not created hence not referring to the inspection lot. This is the cause for this error.

    Now as solution:---

    If you are batch managed then assign the upcoming batch number to the inspection lot (use Trx QA02).

    Or

    Assign any batch number to this lot, because if there will be no batch for the lot, it wont allow the UD.

    So, enter some batch number (e.g. 1234) and perform the UD. Then, if you are not batch manged, you need to deactivate the Batch Management tick, but system wont allow you, hence now there is batch for this material. So, create a new material, that will be copy of this material, (Don't forget to deactivate the Batch Management for it). And transfer the stock, and simply put deletion flag to the wrong material and start using the new one for all the trxns.

    Or

    Reverse all the Documents (inspection lot, RR, GR,PO etc) and deactivate the Batch management (proceed as above)

    Regards,

    Shyamal

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 11, 2008 at 05:08 AM

    Hi Vivek,

    In material master under Plant Data Storage1 -> check Approved batch record required tick active that is the reason it will ask "Create and approve batch record first".

    Follow the below step.

    1.First cancel the current document as well as Inspection lot,

    2. Remove the tick from Material Master under Plant Data Storage1 -> Approved batch record required.

    3. Create new receipt.

    Revert further clarification.

    Regards,

    S.Babusingh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 12, 2008 at 06:54 AM

    .

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.