Skip to Content
avatar image
Former Member

CPU is not supported. Instruction set 'sse4.2' is missing.

When install latest hana express 2.0 in ubuntu 16.04

error message appeared as below:

CPU is not supported. Instruction set 'sse4.2' is missing.

Checking system requirements failed.

So is there more detail on linux requiment for installing hana express 2.0

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • May 04, 2018 at 10:32 AM

    HANA is supported only on Intel processors:

    2399995 - Hardware requirement for SAP HANA 2.0

    Which CPU are you using?

    Add comment
    10|10000 characters needed characters exceeded

  • May 06, 2018 at 08:21 AM

    Daer Bartosz,

    I am getting the same error. Yes i am testing for SANDBOX on AMD Opteron(tm) Processor 6172, 2100 MHz "VM Environment.

    Error :

    "CPU is not supported. Instruction set 'sse4.2' is missing. Checking system requirements failed"


    Thanks

    Reyaz

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 07, 2018 at 02:42 AM

    Hi @Bartosz Jarkowski, I use ubuntu 16.04,

    And here is the cpu info:

    processor : 30 vendor_id : GenuineIntel cpu family : 6 model : 2 model name : QEMU Virtual CPU version 1.4.1

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 25, 2018 at 05:19 PM

    I ran in the same error on a Ravello VM, which worked fine in the past. I can suppress the error with --ignore=check_platform in the hdblcm installer and HANA Express seem to work on the first sight.

    This particular VM has the following info:

    12:49:24.538 - INFO: -----------------------------------------------------------
    12:49:24.538 - INFO: System Information
    12:49:24.538 - INFO: -----------------------------------------------------------
    12:49:24.550 - INFO:   Operating System: Linux
    12:49:24.550 - INFO:   Architecture    : X86-64
    12:49:24.550 - INFO:   Version         : 3.10.0
    12:49:24.550 - INFO:   Subversion      : 327.el7.x86_64
    12:49:24.550 - INFO:   C Runtime       : GLIBC 2.17
    12:49:24.550 - INFO:   Cpu features    : sse sse2 cmpxchg16b
    12:49:24.550 - INFO:   Host Name       : hana1-b286
    12:49:24.550 - INFO:   Manufacturer    : Bochs
    12:49:24.550 - INFO:   Product         : Bochs
    12:49:24.550 - INFO:   Distribution    : Red Hat Enterprise Linux Server 7.2
    12:49:24.550 - INFO: -----------------------------------------------------------
    

    This is a pure test system with no performance requirements, and I do not have any chance to change that

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 10 at 05:45 PM

    I know this issue is old but I found a solution for my case. The linux system I was using was hosted on MS Virtual Machine Manager. In the Hardware Configuration I disabled "Allow migration to a virtual machine host with a different processor version." This change enables sse4.2 and everything was good.

    Add comment
    10|10000 characters needed characters exceeded