Skip to Content
avatar image
Former Member

Missing BAPI Output Parms

Hello VCers -

I have implemented a pretty simple VC model which makes use of a custom BAPI.

The BAPI outputs a table that has three columns.

I built the model, and it worked fine.

I then added two additional columns to the table output of the BAPI, but VC cannot recognize the two new columns of the output table.

Even if I start fom scratch, it does not see them.

When I test the BAPI in VC, it does not see them.

I can test the BAPI in ECC and the two new columns are in the output, so it is not a matter of activating the changes in ECC.

Any idea what the problem is?

Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Nov 07, 2008 at 05:00 AM

    Hi,

    This is because the chnaged BAPI is not reflecting in the VC .

    Solution 1: Go to tools->options->Compiler Tab->select option Do not cache get latest in the Dta service Retrivel Drop down. Refresh and now check the Bapi

    If the above solution not worked follow the below steps :

    https://www.sdn.sap.com/irj/sdn/wiki?path=/display/vc/connection+lifetime

    Govindu

    Add comment
    10|10000 characters needed characters exceeded