Skip to Content

Transporting objects between different PI systems

Hello all,

I am trying to transport the ddesign and configuration objects from my PI system to a PI system on a new server. I have exported all the objects from the old system as tpz files. The Basis hae exported them to the new system.

Now, I could import the design objects into the repository without any problems. However, I am unable to import the configuration objects into the Integration directory.

It is giving me the following error:

=========================================

Import failed because of business system transfer of object Communication Component

| BS_FPN_TEST: Obligatory transport target for business system BS_FPN_TEST not found in System

Landscape Directory

-


Import failed because of business system transfer of

object Communication Component | BS_FPN_TEST: Obligatory

transport target for business system BS_FPN_TEST not

found in System Landscape Directory (BS_MAPPING_FAILED_OBJ)

-


Import failed because of business system transfer of

object Communication Component | BS_FPN_TEST: Obligatory

transport target for business system BS_FPN_TEST not

found in System Landscape Directory (BS_MAPPING_FAILED_OBJ)

-


Obligatory transport target for business system BS_FPN_TEST

not found in System Landscape Directory (BS_TARGET_NOT_FOUND)

-


Unable to find associated SLD element for specified

class (source element: SAP_XIIntegrationServer, [CreationClassName,

SAP_XIIntegrationServer, string, Name, IntegrationServer.pid.svdud01,

string], target element class: SAP_BusinessSystem) (SLD_ASS_NOT_FOUND_EX)

============================================

I checked the source and target Business systems in the new SLD and they are present.

Could someone please tell me why am I getting the error?

All usefull answers will be marked.

Many thanks in advance.

Ramesh.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    Nov 06, 2008 at 09:45 PM

    You need to prepare both the SLDs for transports.

    You need to define the integration servers for source and target systems in both the slds then create transport groups and then assign transport targets in the source and transportation source in target sld.

    Follow the below article of mine..

    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/library/soa/soa-management/exchange-infrastructure/preparation%20of%20sld%20for%20transports%20using%20cms%20in%20xi.pdf

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 06, 2008 at 05:41 PM

    Hello Ramesh,

    Faced similar problems in ID and even after importing its required quite some time to check all configurations are in place! For instance, if its FILE adapter, then we need to change the path of source and/or target file paths from DEV to QA/PROD systems. So its better to create possible configurations manually/by transporting individual objects!

    Please find the blog from Sravya!

    Overview of Transition from Dev to QA in XI

    Hope it is useful to you!

    Regards,

    Jilan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 03, 2009 at 04:47 PM

    The link to Vijay's document in his posting is out of date. Here is the the current valid link:

    [https://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/b01876ac-abbb-2a10-788e-95a7c5a5aeca]

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I am also facing the same issue, while importing the transport in Production, it is failing with below error

      "Import failed because of business system

      transfer of object Communication Channel | QM1 |

      Receiver_FileAdapter_MDMMatmas_PRUE_Inbound: Obligatory transport

      target for business system QM1 not found in System Landscape

      Directory"

      Transport target for QM1 system is defined in both SLDs(Production and Quality). And QM1 is defined as transport source for PM1 in SLD. Still we are getting this error. Please help me to fix this issue

  • avatar image
    Former Member
    Jan 27, 2010 at 03:13 AM

    Hi Ramesh,

    Please make sure BS_FPN_TEST is present and activated in SLD and ID.

    A complete cache refresh and even a server restart is worth trying.

    Regards,

    J Augastine

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 27, 2010 at 12:27 PM

    Hi Ramesh,

    First u have to create Bussiness systemand assign in to Integration server.These create bussiness group and assing the bussiness system.Once u complete the sld restart the server.After that u have to Transport u r developed objects.

    Thanks

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 11, 2011 at 01:56 PM

    Resolved.

    Add comment
    10|10000 characters needed characters exceeded