Skip to Content
0

Issues with RFIDYYWT / S_P00_07000134 running in foreground and background

Nov 03, 2016 at 03:38 PM

226

avatar image
Former Member

We are running S_P00_07000134 - Withholding Tax -> General -> Generic Withholding Tax Reporting for our 1099Misc Reporting
We have few issues when we run in background and Foreground:

1. When we run in Foreground : The report (IRS) file picks only the last Vendor in the list and put the total amount from all documnts under his B record. It does pull teh Transmitter records from ''Country Specific Parameters''
2. When we run in Background : The IRS report breaks the Vendor Company Code wise - We have selected ''Handle Multiple Comp'' to have one Record each Vendor, but seems that is not working.
to add on to the Background run, the IRS report does not read any transmitter records that we entred in out ''Country Specific Parameters''
It looks like the S_P00_07000134 is not readin the country specific parameters.

Please share your thoughts if anyone had the same prbs before.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Jan 13, 2017 at 04:19 PM
0

We are having similar issues. We cannot run in the Foreground because we are getting 'dumps' with our larger company codes and running the t-code in the background doesn't print the Payeer's info on the 1099 form. SAP recommended that we use SA38 to execute RFIDYYW with a variant. (Select Background prior to selecting the Variant). This works great for getting our 1099Misc forms created as PDFs. The 1099MISC file for the IRS also needs to be created in a SAP directory and not on your desktop. This is where we are having problems right now. We cannot seem to get our file created in a readable and correct format. We've tried everything SAP has recommended so far, but it still isn't creating the file properly.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 20, 2017 at 10:58 PM
0

Hi Patti,

We had similar problem with S_P00_07000134 , when running the program in background the country specific parameters where not populated in in DME file.
So I debugged and found out there is a table IDWT_ADD_VARIANT from where the program picks the variant and if you start the background job from selection screen it will not pick the variant.

Solution: This worked for us:

1. Create variant for your specific run.

2. Start your job from SM36 by "Selecting a Variant" in the "Step"

This way the program will pick up the correct variant from table IDWT_ADD_VARIANT

Cheers

Bhanu

Share
10 |10000 characters needed characters left characters exceeded