Skip to Content
0

Web Dispatcher Redirect url is not wokring

May 02 at 04:14 PM

304

avatar image
Former Member

Hi All,

I have a req to redirect from url https://crestrondev.xxx.com/XISOAPAdapter/MessageServlet?senderParty=&senderService=BC_SALESFORCE to http://sappodev.xxx.xxx.com:50000/XISOAPAdapter/MessageServlet?senderParty=&senderService=BC_SALESFORCE I verified the target url is working. I am using parameter

PREFIX=/, FOR=crestrondev.xxx.com, FROM=/XISOAPAdapter/MessageServlet?senderParty=&senderService=BC_SALESFORCE, FROMPROT=https, PROT=http, TO=/XISOAPAdapter/MessageServlet?senderParty=&senderService=BC_SALESFORCE, HOST=sappodev.xxx.xxx.com, PORT=50000

Also I enabled SSL_ENCRYPT=0. The redirect is not happening. Do I need to add additional parameters? The source url is just dummy url. Please advise.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Clebio Dossa
May 02 at 11:38 PM
1

Hi,

On the redirect handler, the FOR must be a combination of hostname + port, like FOR=<host>:<port> .You can use wildcards like "*" also.

You cannot use query strings on redirect handler. So, everything until before the question mark (?) is valid, but after that you cannot use.

A redirect like following should work:

icm/HTTP/redirect_0 = PREFIX=/, FOR=crestrondev.xxx.com:*, FROM=/XISOAPAdapter/MessageServlet, FROMPROT=https, PROT=http, HOST=sappodev.xxx.xxx.com, PORT=50000

Note that I have removed the option TO because, if the URL + query string is the same on the destination, the redirect handler will just copy it. On the above example, all access using hostname "crestrondev.xxx.com" and URL "/XISOAPAdapter/MessageServlet" returns a redirect to host sappodev.xxx.xxx.com on port 50000 using the protocol http.

Regards

Clebio

Show 9 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Clebio,

I tried it and it is not working. I tried with port and without port for FOR value and both of them not working; used as per your advise. Please help.

0

Hi,

It is not only the FOR, you also should not use query string on FROM or TO.

The same parameter I sent you works on my test, so, if you can share the Web Disaptcher with trace level 2 will help to identify what is wrong.

Just few points:

1) You must access using the hostname crestrondev.xxx.com on the brower;

2) You must access using the protocol https;

3) If you do not use wildcard "*" on the <port> option of FOR, you must add the exactly same port of https protocol client is accessing;

Regards
Clebio

1
Former Member

Clebio,

I have the parameter like below now.

icm/HTTP/redirect_0 = PREFIX=/, FOR=crestrondev.crestron.com:*, FROM=/XISOAPAdapter*, FROMPROT=https, PROT=http, HOST=sappodev.crestron.crestron.com, PORT=50000

SSL_ENCRYPT=0

It is still not working. Please advise.

Thanks,

Kavitha Rajan

0
Former Member

All/Clebio,

I have worked with my network Admin and to add crestrondev.crestron.com in DNS and now

http://piposervices.xxx.com:50000/XISOAPAdapter/MessageServlet?senderParty=&senderService=BC_SALESFORCE is opening the page that worked for

http://sappodev.xxx.com:50000/XISOAPAdapter/MessageServlet?senderParty=&senderService=BC_SALESFORCE

The first url is still what displayed in the resulting link. Is this correct? https to http is still not working. Please advise.

Thanks,

Kavitha Rajan

0

Hi,

Is the "HOST" argument correct? "sappodev.crestron.crestron.com"?

And since this is a redirect, once it works the user will see the target URL at the browser ("http://sappodev.xxx.com:50000/XISOAPAdapter/...").

Regards,

Isaías

1
Former Member

Isaias,

Yes the hostname is correct, the domain name has repeated entry. Instead of crestrondev we changed to piposervices. crestrondev/piposervices was not pointing to anywhere, it was dummy. Now with DNS entry it is pointing to sappodev, our target. Now when we call the 2 url in my last thread, it is opening same resulting screen. I activated https in PO system and now the above 2 urls, working as https also. But I have not achieved redirect yet using web dispatcher. Just with network admin help, the public url is working; pointing to target. However not sure why redirect is not working. I need to continue working on web dispatcher now. for port redirect, https to http etc.

The user is NOT seeing the target url at the browser. Please advise.

Thanks,

Kavitha Rajan

0

Hello Kavitha,

One thing that caught my attention... Both "FOR" and "HOST" must have the complete hostname.

Shouldn't "FOR" be set to "piposervices.crestron.crestron.com", then?

Regards,

Isaías

1
Former Member

Isaias,

FOR has only one time Crestron as that Domain is also supported in our environment for all non-sap. Right now whatever we configured using network admins worked for our requirement. When the outside users execute piposervices url, it is reaching target. I have only one issue. The self signed ssl certificate I generated with the original hostname with FQDN, sappodev is not working for piposervices. when I execute https url, certificate warning is not occurring for sappodev, but occurring for piposervices. I tried generation *.crestron.com certificate, it is not at all working with both urls. I tried to generate 2 ssl certificate, it is not working. System is showing that only one certificate for that instance. Even if I create another https port 443, it is picking same certificate and not taking another certificate. Anyone please advise, how do I resolve this? My problem will be solved if I fix this. Our Infrastructure team gave a wildcard pfx certificate *crestron.com which they are using for non sap applications. If I install in my laptop, it is not working. I appreciate all of your help.

Thanks,

Kavitha Rajan

0

Hello Kavitha,

Please read the SAP KBAs 2502649 and 2527968 (S-user required).

I believe it will help with your certificate issue.

Regards,

Isaías

1
Yogesh Patel
May 02 at 04:32 PM
1

Hello Kavitha Rajan,

You can use modification handler for it. Look in to SAP wiki page as below

https://wiki.scn.sap.com/wiki/display/SI/How+to+configure+Web+Dispatcher+to+redirect+to+a+custom+start+URL

SAP HELP page : https://help.sap.com/viewer/bd78479f4da741a59f5e2a418bd37908/7.4.19/en-US/7dad0fd8146c426ca304e54fd36202d2.html

In my case I was forwarding to SID and code example is as below

if %{HTTP_HOST} regimatch QASServer.domain.com* [and]
if %{PATH} regimatch ^/sap/opu/*
SetHeader x-sap-webdisp-target-sid XXX [break]

if %{HTTP_HOST} regimatch QASServer.domain.com* [and]
if %{PATH} regimatch ^/sap/bc/bsp/*
SetHeader x-sap-webdisp-target-sid XXX [break]

if %{HTTP_HOST} regimatch QASServer.domain.com* [and]
if %{PATH} regimatch ^/sap/bc/ui5_ui5/*
SetHeader x-sap-webdisp-target-sid XXX [break]

if %{HTTP_HOST} regimatch QASServer.domain.com* [and]
if %{PATH} regimatch ^/sap/bc/webdynpro*
SetHeader x-sap-webdisp-target-sid ABC [break]

if %{HTTP_HOST} regimatch QASServer.domain.com* [and]
if %{PATH} regimatch ^/sap/bc/gui/sap/its/webgui/*
SetHeader x-sap-webdisp-target-sid  ABC [break]


Hope this helps

-Yogesh

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Yogesh,

I will try this option if the other one did not work at all. And will update you. Also not sure what rule should I use for my req.

Thanks,

Kavitha Rajan

0