Skip to Content
0

SRM:HRALXSYNC background job not synching

May 02 at 08:55 AM

18

avatar image

Hi All,

I tried scheduling the report(HRALXSYNC)as background job.The job run was however successful.

But on checking for few user's the data are not synchronized properly.What could be the reason?

However I tried to debug the report,there were no data present to process it.Not sure what I am missing.

On Debugging the background job

On Checking for one particular user after the background job..still synch issue exist.

Table:T77SO

job.jpg (116.6 kB)
valuenotpresent.jpg (173.5 kB)
hrprog.jpg (84.9 kB)
hrprog.jpg (84.9 kB)
valuenotpresent.jpg (173.5 kB)
synch11.jpg (101.1 kB)
synch.jpg (106.7 kB)
tables.jpg (188.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Daniel Erdei
May 02 at 10:45 AM
0

Hello,

First I recommend you to check if the organization have a valid address with e-mail where the user is assigned.

You can check KBA: 2008038 regarding to the error: "Determinations of connection to object 'S' of 'CP' XXX failed

It contains some checks that you should perform.

Check also the implementation of HRALX_HRALXSYNC_BADI. It can have only one active SRM implementation.

You can also debug the consistency check with USERS_GEN in SRM to find out why the error occurs:

Debugging hints for the users_gen transaction - https://wiki.scn.sap.com/wiki/x/rIf_Eg


Best regards,

Daniel

Share
10 |10000 characters needed characters left characters exceeded