Skip to Content
0
Former Member
Nov 05, 2008 at 06:19 PM

Crystal Reports Server 2008 Installation Error

23 Views

Good day,

My name is Dominic Hung and I work at Business Objects. One of my clients is coming across an installation error on their evaluation of CRS 2008 and is detailed as follows:

They currently have the actual report writer (Crystal Reports 2008) on a desktop PC. It's not installed on the server.

We have the MySQL ODBC loaded on the local desktop as well as the server that is hosting CR2008 Server.

The credentials (userid/password) used in both the desktop and server's ODBC configuration is READ ONLY.

During the installation wizard for CR2008 Server, I key in the userid & password that I use when we create reports, but I receive an error stating that

CMS database error: STU000226

BusinessObjects Enterprise CMS: Unable to connect to the CMS system database "esc:10.127.214.22:3306". Reason: Database access error. Reason access denied for user 'jdcherry'@'% to database 'esc'

This is where everything stops and they can't go further. They are not sure why they are receiving the "access denied" error as shown above. They have no problem connecting to the MySQL database when they create a report using CR2008, the CR2008 SERVER won't accept my credentials during the installation.

QUESTIONS:

The "jdcherry" UserID (which I use) is READ ONLY on the MySQL database that's hosted on the Linux box. Does the userID have to have higher priviledges than just READ ONLY in order to validate the database credentials?

If so, what level of access is required?

Does the installation of CR Server update any of the tables that are stored on the MySQL database?

Do we need to install the Crystal Reports 2008 on the server in order for Crystal Reports 2008 SERVER to work?

What other workarounds can be done for the client? The windows server they have Crystal Reports Server 2008 installed on has web services enabled but are continuing to come across issues. Any insight for the client would be greatly appreciated.