Skip to Content
0

Inbound IDOC to SAP is having a wrong port

May 02 at 06:45 PM

68

avatar image
Former Member

Hi Experts,

I am working on File to IDOC interface in PO 7.5 and have configured all the ALE settings correctly.

I am using XSD for an idoc and using in the mapping as external message and have disabled EDIDC segment as i wanted this to be populated at runtime.

I have also populated all other parent node with the Segments with "1". but still i am getting this error.

"

MP: exception caught with cause com.sap.aii.af.idoc.exception.IDOCAdapterException: Error before sending due to idoc parsing error: (7) IDOC_ERROR_PARSE_FAILURE: Missing required <EDI_DC40 SEGMENT="1"> start tag within IDoc-XML for type <ACC_DOCUMENT03>: state=READING_CONTROLRECORD_STARTTAG, charPosition=97, lineNumber=1, columnNumber=98"

If i enable the EDIDC segment and populate segment = 1, the message is getting succesful in PO but failing at the ECC side and its taking a wrong port "TRFC". ideally the port should be SAP + SID.

Can someone please suggest on this issue.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

dhivakar muthusamy May 04 at 02:15 PM
0

Hi Bhagavathi,

If you have enabled the apply control records from the payload, just disable it. Then the RCVPOR value will be automatically taken from the SAP system as SAP<SID>.

Hope this helps!

Regards,

Dhivakar

Share
10 |10000 characters needed characters left characters exceeded
Priyanka Anagani May 04 at 09:04 AM
0

Hi Prasad,

Have you configured the IDoc receiver channel correctly?

You can set the custom header values in the Idoc receiver channel by selecting "Override IDoc Control Headers". You can also make control record as optional. Double check the channel configuration.idoc-receiver-channel.png


Share
10 |10000 characters needed characters left characters exceeded