Skip to Content
avatar image
Former Member

Web Dispatcher - CRM2007

I have a server with a CRM2007 + Java Addin installation and in another server I have installed a Web Dispatcher 7.0. I have not been able to connect to the CRM shop via the Web Dispatcher, I can access BSPs though.

Web Dispatcher configuration:

rdisp/mshost = my.crmserver.com

ms/http_port = 8104

icm/server_port_0 = PROT=HTTP, PORT=8004

icm/server_port_1 = PROT=HTTP, PORT=50400

Access to ICWeb (BSP) without webdispatcher works ok:

http://my.crmserver.com:8004/sap/bc/bsp/sap/crm_ui_frame/default.htm

Access to CRM Shop without webdispatcher works ok:

http://my.crmserver.com:50400/b2b/b2b/init.do

Access to ICWeb (BSP) with webdispatcher works ok:

http://my.webdispatcher.com:8004/sap/bc/bsp/sap/crm_ui_frame/default.htm

Access to CRM Shop does not work, it gives a blank page, no error message:

http://my.webdipatcher.com:50400/b2b/b2b/init.do

After that I added this two lines to webdispatcher configuration:

wdisp/J2EE/group_info_location = /JavaEE/public/icf_info/icr_groups

wdisp/J2EE/url_map_location = /JavaEE/public/icf_info/icr_urlprefix

in the Visual Administrator I added:

/JavaEE/public/icf_info/icr_groups for GroupInfoRequest property

/JavaEE/public/icf_info/icr_urlprefix for UrlMapRequest property

and in the Netweaver Administrator I created a logon group for the Java Instance, still I get a blank page for the CRM Shop.

My guess is that the Webdispatcher is sending all the request to the Abap stack, what can I do for the Java request to be dispatched by the Java Stack?

Regards,

Ayax

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Nov 04, 2008 at 08:33 PM

    Open your IE and go to the URL: http://my.crmserver.com:8104/msgserver/text/logon

    Post the result.

    There could be a way to help you.

    Regards,

    Slava

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 04, 2008 at 08:39 PM

    Hello Slava,

    The output is:

    version 1.0

    mycrmserver_SID_04

    DIAG my.crmserver.com 3204 LB=16

    RFC my.crmserver.com 3304

    HTTP my.crmserver.com 8004

    J2EE my.crmserver.com 50400 LB=1

    J2EES my.crmserver.com 50401 LB=1

    Thanks in advance.

    Regards,

    Ayax

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 05, 2008 at 08:43 AM

    Hi,

    In the profile of your CRM 2007 system, did you set this parameter ?

    is/HTTP/default_root_hdl = j2ee

    I have an PI system where HTTP requests go like this

    internet ---> Apache --> web dispatcher --> PI abap ICM --> PI java stack

    I had to set this parameter to make it work.

    The ICM acts as a sort of reverse proxy for java requests.

    Regards,

    Olivier

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 05, 2008 at 03:11 PM

    Hello Olivier,

    I checked in RZ11 and is/HTTP/default_root_hdl default value is j2ee, I also checked it in SMICM -> Goto -> HTTP Server -> Display Data:

    ABAP Server operational = TRUE

    J2EE Server configured = TRUE

    J2EE HTTP port = 50400

    J2EE HTTPS port = 50401

    J2EE Server operational = TRUE

    Default root access handler = J2EE

    URL Prefix Table loaded = TRUE

    So that does not seem to be the problem.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Ayax,

      >So that does not seem to be the problem.

      I agree !

      I reread your first message and this configuration seems strange to me :

      >Web Dispatcher configuration:

      >rdisp/mshost = my.crmserver.com

      >ms/http_port = 8104

      >icm/server_port_0 = PROT=HTTP, PORT=8004

      >icm/server_port_1 = PROT=HTTP, PORT=50400

      Why did you define 2 ports for HTTP on the web dispatcher ?

      It seems that you think that it's necessary to use the same ports on the webdispatcher than on the CRM system. This is not true.

      Usually you would use only 1 port for HTTP (and why not the standard 80 http port ?).

      Did you try to call ?

      http://my.webdipatcher.com:8004/b2b/b2b/init.do

      Regards,

      Olivier

  • avatar image
    Former Member
    Nov 05, 2008 at 04:59 PM

    Hello Olivier,

    It seems odd to have two ports for HTTP, I started with just the standard port with the same problem so I tried to distinguish java from abap request, at the end I guess there is no difference but it is not working anyway.

    I tried http://my.websdipatcher.com:8004/b2b/b2b/init.do but same problem persist.

    Regards,

    Ayax

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello again,

      Set this parameter icm/log_level = 2

      in your Web Dispatcher profile. Restart the Web Dispatcher

      Retry the URL and look at the trace file (usually dev_webdisp ) to see if you get meaningful messages.

      Regards,

      Olivier

  • avatar image
    Former Member
    Nov 05, 2008 at 11:05 PM

    Hello Olivier,

    I created an OSS Message and was requested to increase the trace level to 3, both in the web dispatcher and crm server, I sent the trace files to SAP and I am waiting for their response.

    I did check the traces but found nothing helpful, in part because I do not know what to look for, if anyone else can help would be appreciated, if I get the problem solved by SAP I will post the solution.

    Regards,

    Ayax

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 06, 2008 at 04:29 PM

    I was asked by SAP support to deploy corrections from SAP Note 1068501 and problem was solved.

    Regards,

    Ayax

    Add comment
    10|10000 characters needed characters exceeded