Skip to Content
avatar image
Former Member

Deleted/ Added BOM components are not replicating from ECC to CRM

Hi All,

We are deleting the components from the BOM using CS02 in ECC . But those are not replicating from ECC to CRM . If I do the request load ,only added components are updating in CRM but not the deleted components . The components table COMM_IL_STRSET is not updating when I am doing deleting . It is working fine in quality and dev environment . We are using the adapter object BOM.

Could you please help me what is the issue in this?

regards,

ram

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • May 03 at 06:12 PM

    Do some searching as there are Resources on this :

    • SAP-Help Replication BOM ECC CRM : link
    • SAP-KBA 774347 Collective Notes on BOMs : link
    • SAP-KBA 1790484 BOM Explosion in CRM doesn't work using object BOM_ERP: link
    • SAP Blog BOM Settings in CRM ECC System : link

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 04 at 11:18 AM

    Already I gone through those documents . after reading those doucments only I posted the issue.

    thanks,

    ram

    Add comment
    10|10000 characters needed characters exceeded

  • May 07 at 11:07 PM

    I following notes with keyword COMM_IL_STRSET

    2382456CRM-MD-PRO-IFError in BOM download from ECC to CRM after BOM update

    2515190CRM-MD-PRO-IFError in BOM initial load from CRM system

    1270620CRM-MD-PRO-IFBOM download gets stuck in the queue

    1156808CRM-MD-PRO-IFFAQ: CRM Master Data Products Data Download(Data Exchange)

    Add comment
    10|10000 characters needed characters exceeded

  • May 22 at 10:42 AM

    Hi Ram,

    Looks like the delta load is not working during BOM change using CS02. Make sure that table TBE31 has entry for EVENT= CS000010 with function module name CRS_BOM_COLLECT_DATA in ERP system. Since the request load is working, I suppose the RFC destination information and object details are correct.

    Also note that the request load from CRM system is not going to update the deleted components. These entries may need to be deleted manually from CRM system OR once the delta load is working, add the components again in ERP,save the data and delete them. Doing so, the delete operation is sent to CRM system and thereby deleting the components in target system.

    Regards,

    Athreya

    Add comment
    10|10000 characters needed characters exceeded