Skip to Content
0

Resource JavaSript file - Update ignored

May 02 at 06:50 PM

35

avatar image

Dear experts

could you please help me? I am struggling with JS resources. I have a JavaScript file uploaded as a resource. then I changed the file and uploaded the change.

Following this question

Personas 3.0 - Update javascript resource file,

I should automatically get the new version. But in my case that's not working. I still get a previous version. Closing browser or even using another browser (IE instead of Chrome) doesn't help :-(

How can I analyze what's going on? Or is there some kind of cache I need to refresh?

We are on Personas 3.0 / SP 6.

Kind regards

Meinrad

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Cristiano Hansen
May 02 at 08:34 PM
0

Hi Meinrad,

You can use the developer tools to check whether the new version is being loaded.

Of course, you can clear web browser cache and server cache:

/nSMICM -> Goto -> HTTP Plug-In -> Server Cache -> Invalidate Globally.

Via Personas you can also have the same results as above:

/n/PERSONAS/ADMIN -> Health Check -> menu "Health Check" -> Cleanup -> Clear MIME Cache

What happens then?

Kind regards,

Cris

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Cris,

I have good News and bad News. Bad News is none of your suggestions worked. Good News is I found another way. I "just" have to edit description of the resource . That helps and I can continue.

But... I believe that your suggestions should work (if invalidating caches should benecessary at all). And I noticed another strange thing. The result list of the resources does not show correct properties.

Please note that Resource Description is empty for the second item on the above list. Please note also that it is not public according to the search result list.

But the corresponding details look like this:


So either there are some bugs or our system is not set up properly. Do you have any opinion on that?


Regards

Meinrad

0

Ups - sorry. Forgot to comment on developer tools.

a) I could not find the JS in the resources.

b) Checked the network traffic and found the following requests

sap/bc/personas3/resource/0050569B26BA1ED893C679748408C0E1?version=20180503053924

sap/bc/personas3/resource/0050569B26BA1ED893C679748408C0E1?version=20180503060204

the URL parameter version changes when I change the resource description and save it.

0

Hi Meinrad,

I would recommend to raise an incident with us. The fact that the description is not updated is one thing I believe needs to be fixed.

Thank you very much,

Cris

0