Skip to Content

IDM v8 - Make Process Public

I just installed IDM v8 in a DEV environment and I'm trying to create a process that will execute anytime a new MX_PERSON record is created. To do that, I need my process in my custom package to be a public process so it can be references outside of that package. According to SAP documentation, it should just be as simple as right clicking that process and selecting the, "Make Public" option, as long as the package is checked out, which mine is. When I select the, "Make Public" option, the pulldown menu disappears but my process is still marked private, i.e. has the blue, not green, task icon and the Qualified Name field is still empty.

Any suggestions? When I look at the entry for this task in the MXP_Tasks table and compare it to other public tasks, I don't see anything in the data that would signal to me why this won't work. Additionally, when I try to create processes in other packages that have public processes and then make my new process public, it won't work there either so I know the settings of my package aren't blocking my efforts.

This one is driving me insane! :)

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    May 23 at 08:03 PM

    For all that are following this post, our issue has been solved! When we first had this issue, we hesitated to submit an OSS ticket because we were on SP5. We knew that they first thing SAP would say would be to upgrade to SP6 and if it still didn't work, then we could submit a ticket. Thus, we did the SP6 upgrade and the issue still persisted and so, we opened an OSS ticket.

    When SAP logged in via WTS, they noticed a couple components were somehow still on SP5. No idea how most components, core, Eclipse, DB, etc. were all updated but REST API and DevStudio Service were still on SP5. So we tried again and this time, everything got on SP6. This solved this issue. We're able to make processes public. Whew! :)

    Add comment
    10|10000 characters needed characters exceeded

  • May 03 at 07:10 AM

    Hi Brandon,

    I know this is a very generic question, but as you did not mention the name of the process I will ask it: Do you have spaces or special characters in the name of the process?

    Regards

    Norman

    Add comment
    10|10000 characters needed characters exceeded

    • The name of the process has no illegal characters. It is, "NotifyContractorCreate". Originally there were spaces between the words but IDM gave me the warning message to eliminate them. Once I did, I thought I would be OK. No go.

  • avatar image
    Former Member
    May 15 at 02:07 PM

    Hi Brandon

    Just wondering if you got any further with figuring this out? We are having the same issue.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

    • I have no problems with any of the default forms that come with IDM v8. I'm only having the Make Public issue and I also cannot link a script from one package, that is already marked public, into another package. SAP has responded to the initial OSS ticket requesting a WTS connection so hopefully answers are coming soon.