Skip to Content

SOAP Synchronous scenario :: XI 7.0 :: Response invisible in any Log !! QOS ??

Hello Team,

I have a situation where I need some help figuring out what's going on.

Existing scenarios :

PROXY to FILE - a file is sent to the third party with a query. FILE to PROXY - a file with the answer to above query is received from the third party.

Requirement : PROXY to Webservice - Query is sent via webservice request to third party Webservice to PROXY - Webservice response from third party contains answer to above query.

I have followed this tutorial -> https://blogs.sap.com/2013/07/07/proxy-to-soap-synchronous-scenerio-in-pi/

The Webservice request is received by the third party successfully. They have also sent SAP PI the answer in their response. However, I'm unable to view this response in any of the logs in PI. I have also used XPI Inspector to trace this transaction - No use.

Note: Two different PROXY's are used for Request & Response in ECC (I hope that's not the problem) Ive also noticed in MONI that the QOS is "EO" & not "BestEffort". If this is the problem, where do I change it ? Any help is much appreciated.

Thanks & Regards

Sam

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • May 02 at 09:52 AM

    Dear Sam Anish,

    Basically, you may have configured your interface in Asynchronous mode, thats the reason you couldn't see service Response.

    You need to correct config as Proxy-to-Soap Synchronous outbound.

    Two Service-interfaces (inbound/outbound synchronous) required.

    Regards,

    Dilip

    Add comment
    10|10000 characters needed characters exceeded

    • Dear Sam Anish,

      Your config seems to be incorrect, else you should have received an mapping error during response, because this mapping error will be due to non-receipt of web-service response payload.

      And have you checked web-service too using some std. tool like 'soapUI' to get the idea about response payload.

      You can show me all config SI,OM, RD, ID, RA and soap channel...

      Have you checked the log of soap channel ?

      Regards,

      Dilip