Skip to Content
author's profile photo Former Member
Former Member

Disable input for material text in VA01

We need to disable input field VBAP-ARKTX in VA01 transaction. We need to turn this field as output only and no user entry should be possible. This is item text field at line item.

How can this be achieved.

PLZ Help!

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Nov 01, 2008 at 11:32 AM

    Hi,

    You could try making a transaction variant of VA01 in tcode SHD0. When created then go to tcode VOV8 and set the variant for the ordertype.

    Regards,

    Bert

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 01, 2008 at 01:14 PM

    >

    > We need to disable input field VBAP-ARKTX in VA01 transaction. We need to turn this field as output only and no user entry should be possible. This is item text field at line item.

    > How can this be achieved.

    >

    > PLZ Help!

    Please check the subroutine userexit_field_modification in the include program MV45AFZZ

    In addition to this there is also a customer exit provided by SAP to meet this requirement, please search

    for the same.

    Edited by: Rajesh on Nov 1, 2008 6:54 PM

    Check this function exit EXIT_SAPMV45A_004 in the enhancement V45A0003

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 03, 2008 at 05:24 AM

    I've checked oth the above exits. the item text appears in the table control. As found the above mentioned exits do not take care for the table control values. But my requirement is to disable the item text at line item level appearing in the table control. Plz let me know if it can be achieved at the earliest.

    PLZ HELP!

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 03, 2008 at 08:12 AM

    Hi,

    you can disable thro customizing. ask functional guy to disable the field.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.