Skip to Content
0
Former Member
Oct 31, 2008 at 10:39 PM

SAP MMC could not create snap-in after server restart

229 Views

Dear SAP Experts,

Greetings!

I am facing a situation were the SAP Instance is unavailable in the SAPMMC.

I had an EP 6 system installed only with the JAVA instance on Windows 2003 server with MS SQL. I had the installation and configuration of SLD, User Mapping, UME, and Knowledge Management successful.

I wanted to install SAPGUI in the server for accessing my R3 systems. After installing the SAPGUI, I had to restart the portal server. After this I am not able to find the SAP instance of the Portal system in the SAPMMC.

I tried all the methods to regain the SAP Instance Snap-in

1.Tried to Add a Snap-in from the SAPMMC u2013 but when I try adding the Stand Alone Snap-In, I get an error message MMC cannot initialize the snap-in name u2013 SAP Systems Manager

2.Starting the SAPSERVICES - SAP<SID>_00 & SAP<SID>_01 u2013 It gave an error message that u201CSAP<SID>_00 service could not be started, it comes up with the error: the SAP<SID>_00 service on Local Computer started

and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service.u201D

3.Changing the logon of the services after changing the logon userID from SAPService<SID> to <SID>ADM u2013 I again encountered the error message that was mentioned above.

4.Checking the Path to Executable for both the services. u2013

(SAP<SID>_00 - E:\usr\sap\<SID>\JC00\exe\sapstartsrv.exe

pf=E:\usr\sap\<SID>\SYS\profile\START_JC00_hostname) & (SAP<SID>_01 - E:\usr\sap\<SID>\SCS01\exe\sapstartsrv.exe

pf=E:\usr\sap\<SID>\SYS\profile\START_SCS01_hostname)

5.Checking the share sapmnt and saploc and the access permissions for the same.

6.Starting the SAP System from the command line u2013 I get

message u201CSTARTSAP Continues u2026u201D

7.Starting the sapstartsrv.exe from the SAP Executables - In this try I got an error message mentioning that the DYNAMIC LINK LIBRARY LIBRFC32U.DLL COULD NOT BE LOADED.

When I searched for the dll file in the server, I found the same in the SAPGUI Installation CD Dump and no-where else.

Could the Installation of SAPGUI 7.10 in the server cause any user permission problems or file permission changes?

I remember a message that appeared when I was installing and

uninstalling the SAPGUI, it is mentioned below,

Please switch your Terminal Server to install mode before running SAPSetup. You can do this using the command line "change user /install" and reset to execute mode using "change user /execute" after installation.

Do you want to correct your server mode now?

Please advice on the same. Could this cause any changes to the library file and pull down my server when it was restarted?

What should I do now to get back the instance in the SAPMMC and continue the normal working with all my old configurations?

Expecting your reply at the earliest.

Thank you

Regards,

Vineeth Damodar