Skip to Content
avatar image
Former Member

Help me Expert: SAP UNI-CODE AND NON-UNICODE

Dear Expert,

I'm come from Thailand. I have a problem when I trasfer data via IDOC from system A --> system using SAP XI

System A: is uni-code system

System B: is non-unicode system

I send data using IDOC ORDERS05 in one segment there is value "กรกช" .After this IDOC is send to system B. the data which is determined for this segment is "####". >.<

I try to set config to log-on By 'TH' (Thailand lang) for system B when transfer it work! but my support team not suggest to do it... can I do other ways..

Best Regards,

@tom

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Oct 28, 2008 at 01:04 PM

    check the rfc destination pointing to Xi system in R3 is made unicode or not.

    it should be changed from non unicode to unicode.

    chirag

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      The user in RFC destination which you are using to Login to System B should also use the language THA. It will work then.

      Kulwinder

  • avatar image
    Former Member
    Oct 28, 2008 at 01:24 PM

    Thank you for fastly answer ^^

    the XI system can receive "กรกช" to "กรกช" in SAP PI

    but when data come in system B(non-unicode system)

    "กรกช" is going to be "####" . How should I do ?

    Best Regards,

    @tom

    Add comment
    10|10000 characters needed characters exceeded

    • There is really no reason why a RFC user from XI could not log on TH language in the target system, if that is indeed the desired language.

      Also, since it's not Unicode, you won't be able to parse these special characters in EN language, so you're out of options here.

      Just change the language, it's no problem at all.

      Henrique.

  • avatar image
    Former Member
    Oct 28, 2008 at 02:28 PM

    Thank you for all help @_@ but I still have a problem

    my system B is not support unicode . . .

    And I cannot logon in TH language because there is a lot of concern by my support team (they don't allow me to log on by TH from XI)

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      then u can not do anything.

      u have only two options

      1) system should be unicode compliance

      2) logon with the TH Language to see the message.

      i think u have to check with ur support team.

      chirag

      close thread once it is solved

  • avatar image
    Former Member
    Oct 29, 2008 at 02:49 AM

    Sry But I have really question,

    I have log on 'EN'

    When I sent "กรกช" (Thai) from system A and set non-unicode in RFC mode ---> XI see "####"

    When I sent "L??" (Gereman) from system A and set non-unicode in RFC mode ---> XI see "L??"

    *my system is not have log on languaue = "TH" (becauase system A is uni-code system)

    that is a question that in system A should have log on as "TH" or not

    IF system A have "TH" logon the system can sent it "กรกช" --> XI see "กรกช"

    sry "Chirag Gohil" and thx for your help ...

    Best Regards,

    @tom

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      As suggested above, When your system is sending TH as language and its Unicode enable, PI is also unicode enable system and will accept data as it is.

      So sender system logon under TH language will solve your issue. RFC will also send data under TH as language.

      Thanks

      Gaurav

  • avatar image
    Former Member
    Oct 29, 2008 at 07:40 AM

    thx alot ,

    my sender system have no 'TH' log on, I will try to advise with basis team to test it whether it work or not.

    Best Regards,

    @tom

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      I advise u to first change the RFC destination from non unicode to unicode in System A.

      u need to check the RC destination and option MDMP&Unicode option and check the communication type with target system

      once u do that it will work fine and u will see the expected result in XI.

      chirag.

  • avatar image
    Former Member
    Oct 29, 2008 at 11:32 AM

    T__T waiting sign from GOD!

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 29, 2008 at 11:33 AM

    thank you all suggestion _ again and again

    Add comment
    10|10000 characters needed characters exceeded