Skip to Content

Gateway monitor is deactivated in SMGW

Hi,

a NW04s system on Windows with MSCS (Microsoft Cluster). From few days SMGW tcode returns an error message:

"Gateway monitor is deactivated"

If we run gwmon outside the istance (from Windows command line from on node, as example), gateway should works because we can see any connection.

gw/monitor = 1

Have you got any idea ?

Regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Oct 22, 2008 at 09:21 PM

    In SM21 there are:

    23:16:48 DIA 000 100 USER SMGW Q0 I Operating system call recv failed (error no. 10053)

    17312 Dialog work process No. 000 USER STATION 2 SMGW RSMONGWY_ALV K SAP Web AS Problem STSK

    Further details for this message type

    Module nam Line Error text Caller.... Reason/cal

    nixxi.cp 4424 recv10053 NiIRead recv

    Documentation for system log message Q0 I :

    The specified operating system call was returned with an error.

    For communication calls (receive, send, etc) often the cause of errors

    are network problems.

    It could also be a configuration problem at operating system level.

    (file cannot be opened, no space in the file system etc.).

    Additional specifications for error number 10053

    Name for errno number WSAECONNABORTED

    No documentation available for error WSAECONNABORTED

    Technical details

    File Offset RecFm System log type Grp N variable message data

    518 313560 m Error (Function,Module,Row) Q0 I recv10053 NiIReadrecv nixxi.cp4424

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      You need to make sure

      SAPLOCALHOSTFULL = localhost (Do not enter name of local host your entry shd be localhost

      SAPLOCALHOST = <Logical host name> (You need to eneter logical hostname)

      Cheers !

      Manish