Skip to Content
avatar image
Former Member

SOAP adapter in PI 7.1

Hello, expert,

I have made SOAP adpeter work in PI 7.0, however after upgrading to PI 7.1, I have issue with a test scenario as following.

I've defined DT, MT and SI (Service Interface) in ESR (no mapping needed)

In ID, I configured a scenario SOAP --> PI --> File.

I tested the scenario in RWB using the test tool for adapter engine using URL:

http://host:port/XISOAPAdapter/MessageServlet?channel=:BC_comp:CC_Notification_SOAP_Sender

the message is attached in the end of this post.

The message was successfully send to PI and saved to file, however the message going into IE pipeline and finally saved to the file is not the one I sent.

Message sent to SOAP adapter:

<?xml version="1.0" encoding="UTF-8"?>

<ns0:MT_Notification xmlns:ns0="http://mynamespace/xi">

<Notification>

<Number>12345</Number>

<Type>abc</Type>

<Status/>

<OrderNo/>

<FunctionalLocation>qaz</FunctionalLocation>

<StartDate/>

<EndDate/>

</Notification>

</ns0:MT_Notification>

Message going into IE pipeline and further saved to file:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

<!-- Inbound Message -->

http://schemas.xmlsoap.org/soap/envelope/" xmlns:sap=" http://sap.com/xi/XI/Message/30" xmlns:xlink=" http://www.w3.org/1999/xlink">

payload-29092409f6d11ddc4d982a0c41f100csap.com">

<sap:Name>PayloadName</sap:Name>

<sap:Description>PayloadDescription</sap:Description>

<sap:Type>Application</sap:Type>

</sap:Payload>

</sap:Manifest>

Also in sxmb_moni, there is a acknowledgement which do not expect.

Does anybody have an idea how this happens?

Thank you

Jayson

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 21, 2008 at 04:17 PM

    Hi!

    I want to answer this thread as 2 parts:

    1. First check all of your configuration whether you have done...correctly or not later please activate all of your objects...

    then try your Scenario once..if not do one thing..

    2:

    I my sugestion is Why don't you try yourr scenario by using either SOAP CLient Tool or else ALTOVA XML SPY TOOL...

    Here I am provding the Steps to be followed to use ALTOVA XML SPY Tool

    please make sure even though you have done correctly..

    Steps for Testing via ALTOVA>>

    1. Go to ID-> TOOLS-> Define Web Service

    2. Give following URL in following window

    For without Party:

    note: http://<HOST name:5<Port>00/XISOAPAdapter/MessageServlet?channel=:<Channel Name>:<Adapter Name>

    3. Give Message Interface Name of Scenario

    4. Give following details in following screens Service Name, Message Interface Name, Namespace

    5. Finish & Save the WSDL in local folder to give to web-services

    (Generated WSDLu2019s attached in Technical Design Document)

    NOTE: AFter generating you can observe the above SOAP URL with your objects name...

    6.Once the WSDL file is created. Use a SOAP client tool or else aither ALTOVA XML SPY Tool to create the SOAP request.

    You can create SOAP Request from WSDL using the following tool

    Once you have created the SOAP request, use the same as the payload and test the scenario.

    7. Select the option in the SEND SOAP REQuest in the MENU present in the top list of ALTOVA XML SPy Tool and give inputs i.e., SOAP URL and also give server details and it will ask authentification details

    8. Now by giving Authentification details you can send successfully....

    9. Now Got SXMB_MONI and now check your scenario is success or not..

    10. IF not go to MEssage monitoring in RWB and check at both the INtegration Server Level and ADAter engine level and then Check the AUDIT LOG

    11. ALso you can check Audit log in COmmunication channel monitoring

    12. If your SOAP Channel is in Red check Errors and then stop that channel manually and start once again and try the scenario once again...

    http://help.sap.com/saphelp_erp2004/helpdata/en/ae/d03341771b4c0de10000000a1550b0/frameset.htm

    I hope it will be useful to you in final case...Suppose if it is useful to you please close this and award points to the repective contributors if it is useful to you..

    Regards:

    Amar Srinivas ELi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Amar,

      thanks for your response. All my objects are activated, I can't see anything wrong in my configuration. If there is anything wrong in my config, there should be more reasonable error in RWB or sxmb_moni. The outcome of my scenarios just so weird.

      I also want to test using external soap client tool, however my clicent has very strict rule that no external software can be installed in the computer. Thus I am stuck with RWB test tool.

      I can also try with wsnavigator, however in PI 7.0 we could test ws in wsnavigator using local wsdl file, but in PI 7.1 it only works with url link that points to wsdl. So my next question is how can I post the wsdl of my soap sender adapter web service to PI server so that such a link like http://server:port/mywebservice?wsdl can be generated which posints to the wsdl of the web service corresponding to my sender soap adapter?

      Thanks alot

      Jayson